Origin not being set


(Donnie Smith) #1

I loaded the new version tonight and noticed that no matter how many times I click on the “Set Origin” button, LB reverts to the last used origin. I have to move the laser to the correct position, close and restart LB, then the Origin is set to 0,0,0. When I move the laser at that point and click on the GoTo button with 0,0 it goes to the proper location.


(Oz) #2

LightBurn doesn’t change your system origin, it just remembers the location you set and moves there before running a job. If I changed the start location to 0,0, the click-to-jog feature and absolute positioning wouldn’t work any more.


(Donnie Smith) #3

Oz, that is what I am saying. I was trying to use the same verbiage as in LB. If I move the laser, click on “Set Orgin”, then click on start… LB moves the laser to the position where the laser was when I started LB, not the place I set he origin. I have to move the laser, close LB, open LB, then start the job to get it to start at that location.

Using CNC terms, how do I set XYZ work 0 before pressing start to run a job?


(Oz) #4

Ahh, ok. In that case, what does pressing “Get Positions” tell you? (on the Move window). If the numbers reported by your machine are negative, they’re considered outside the workspace and will be clamped.

The first paragraph here might help: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md


(Donnie Smith) #5

Thanks for the response. I read the info you linked but my machine is an xcarve 1000. I’ve not had any issues setting the work 0 with other software (i.e. UGS, Picsender, Easel). I just move the router and then press the proper button to set the work 0 (not home). After that I can move my router and then hit return to work 0 and it goes there.

With LB, this is not happening. I move the router/laser, press set orgin, then move the router/laser again. When I hit “Go To X0 Y0” it moves to the location where the router/laser was located when I started LB.

I hope this make sense.

Donnie


(Oz) #6

LightBurn’s “Set Origin” button does not change the machine origin, ever. You should set 0,0 to the front left of the machine. LightBurn’s Job Origin is not the same thing as your machine origin - it is simply a remembered location that is recalled when you run a job in “User Origin” mode. When you click “Set Origin”, you’re setting the start point for the job, not zeroing your machine as you might be used to.

LightBurn doesn’t work like standard CNC software because it runs on a variety of dedicated DSP laser systems in addition to GCode based machines. This is standard workflow for those systems, and allows querying the absolute location of the head on the machine, and jogging anywhere on the bed without exceeding the machine limits, regardless of where your job origin is set.


(Donnie Smith) #7

Ok, I’m starting to understand. Let me approache this from a different angle…

When I open LB, move the laser to where I want the job to start, what are the steps todo to tell LB:

  1. “Here is where I want the job to start?”
  2. “Here is where the job should start and if I move the laser where I want the laser to return to by clicking _________ ?”

Sorry for being a pain but I’m just trying to figure out how to reset the job start after I open LB and move the head without having to close LB and start it again.

Thanks,

Donnie


(Marc) #8

Hi,

Move the laser (manually) to your 0,0 before opening LB
When opening, LB memorize this x,y position as machine origine.

Il you want to start anywhere else (by targeting with laser), move laser at your desired start point, and in Laser Window, select Start From: Current position

Once the work is finished, the laser returns to this new position (unless you have defined another one with the option “Set finish position” in the Move window)

:slightly_smiling_face:


(Oz) #9

Not true, but appear so in some cases. When you power up your controller, if it homes with limit switches, that sets the origin. If there are no limit switches, wherever the machine is on power up is the origin. Either way, it’s entirely a function of the controller, not LightBurn.


(Donnie Smith) #10

This is getting to the heart of my question and issue. As it stands now, I have to start LB or another GRBL controlling sw package, move my laser to the 0,0 point (no homing involved), close LB or the SW I am using, then start LB to set the 0,0 point.

What I am looking for is a way to open LB, load the job, move the laser, set the 0,0 point then start the job. This way, if for some reason I need to move back to the 0,0 point, I can stop the job, click on go 0,0 and I’m back to the exact start point.

This is also handy when going to a new project/job. If I have changed out the wood/tile/whatever then I can reset the 0,0 point without have to close and open LB.

Thanks,

Donnie


(Oz) #11

Set User Origin and Go to Origin do exactly this, they just don’t use “0,0”. “0,0” is the origin of your machine, and doesn’t need to be changed, so I’m not sure why this detail is so important to you.

You should read through the GRBL setup blurb here to make sure you’ve set things properly: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md