Ortur Lm2 15w x axis issue

Good morning! I have had my LM2 for just shy of a year now and it has been flawless until a month or so ago and long story short Ortur sent me a new motherboard and the grounding kit. Well I finally got around to installing the new board and grounding kit today and all went smoothly. I connected to my computer and lightburn and it homes fine on the y axis not I get nothing on the x at all. It won’t move to any position not just home. Y axis seems to be fine. I have checked all connections, disconnected and reconnected as well. Has anyone had this issue and can point me in some direction?
Thanks, Isaac

can you share a few images
MOtherboard conenctors, X and Y connectors and specially the pinboard over the Y motor?

Is this what you’re askin for?




Visually all seems fine
Do you think you can bring the X stepper cable and plug it into the Y stepper motor
Then try to jog X axis, will Y move at all (driven by X?)

Switched cables and still no movement. There is humming coming from x stepper though as was before switching cables. Here is a pic of what console is saying.

Does Y-stepper motor work correctly after cable swap?

If so, then mostly likely X-stepper is bad.

Can you look carefully into the port where the cable connects and make sure there are no bent pins on the stepper side?

The idea is to isolate the X on its own
IF just X cable can Move Y motor
but X cable cant move X motor, then we know is the X motor thats at play
But we need to isolate it though

Sorry I think I misspoke. Right now nothing is plugged into the x motor and x cable is plugged into y motor. When I try to home nothing moves and I hear humming from y motor as I did from x motor originally. Hope this makes sense.

Is there anything else I can do to narrow down the problem?

2 more tests:

  1. Plug Y cable into X Motor. Does X Motor now move with Y controls?
  2. Plug Y cable (the one that is known good) into X port on controller side and into Y motor or X motor (if X motor worked in previous test)

If test 1 works, then X cable or X-port on controller is bad. We can narrow down with second test.
If test 2 works, then X cable is bad. If test 2 does not work, then X-port is bad.

Ok! I will do these as soon as I am back at my laser.

Ok I plugged y cable in x motor and the x motor moved. I’m not quite sure how to do the second test because the x and y cables are all into one plug at the motherboard end. Unless I’m missing something.

Ah… forgot about that. Well at least you’ve proved out that X motor is functioning.

As for the second test… do you have any wires/connectors for breadboarding that you could repurpose for this? Or if you’re adventurous you can actually remove the metal connectors from the plastic housing by gently pressing something into the back of the housing where the connector is exposed. Just take a picture of the connectors beforehand and even tie-off the 2 sets of cables so you don’t get them crossed. Then plug the Y set of connectors into the X positions. It’s not hard, just a little tedious. Just don’t use too much force pulling out as you can rip the wire from the connector.

Not sure how comfortable you are with this sort of thing.

I’ll see if I can coMe up with something tomorrow. Thanks for the help.

Ok after looking at the tiny connectors I’m not too sure about taking them apart. I have zero patience sausage fingers and horrible luck. Never a good combo for this sort of thing. :joy::joy::joy:

Yeah, it’s not trivial if you haven’t done it before.

Do you have a meter that you could use to check continuity in the wires? That would be enough to confirm if there’s a problem with the cable and narrow it down to a controller issue.

I sure do have a meter. Would you be willing to walk me through the process? My electrical and electronics knowledge is limited, but I’m learning.

No sweat. Continuity is one of the easier things to check. The line is either continuous or it’s not.

  1. Turn multimeter dial to Continuity - should look like a diode symbol or sound wave symbol. If your meter doesn’t have a dedicated continuity check just look for the OHM symbol and use resistance to check continuity. Make sure it’s working by touching the leads together. It will beep if you have an audible tester. If measuring resistance then it will go to zero or nearly zero with continuity. This basically means that electricity is flowing through the leads unimpeded since you have a direct connection.
    image
  2. Touch one lead from the meter to one connector on one side of the cable. Find the corresponding connector on the other side and connect to the other lead to that side. You should get a beep or 0 resistance if there is continuity.
  3. Repeat this for each connector.

If you have trouble contacting the connector then stick a pin or something in the connector to essentially extend the connector so you can touch it more easily.

If all connectors prove fine then you’ve narrowed the problem down to the controller port or something on the controller itself.

If you find a fault then the cable itself is bad.

It’s possible there’s something wrong with the firmware on the board as well but doesn’t seem as likely.

I will do this today. I couldn’t get to it yesterday. Thank you for you help and patience.

Ok so I checked continuity to each wire on the x cable and all checked ok.