Ortur Rotary Chuck on OLM2 Pro S2 not working

Hi, I’ve been using my OLM2 Pro S2 for the last two week with Lightburn and I love it. I decided to install the Ortur Rotary Chuck a couple of days ago, but I can’t find a way to make it work. I’ve written to Ortur but all they gave my is a link to install it on LaserGRBL… Not much help. The The Red light is blinking, blue light is steady. Noting moves… I get this message if I try to make the head move, “error:9
G-code locked out during alarm or jog state.
On or near line 0:” Help!!! Thanks.

Please share the rest of the output to the Console window before you see the error:9 message - usually there is an Alarm message preceding error:9, which could tell us more.

It’s possible you’ll see an Alarm 2 error message. If so, that’s because you are commanding your laser to travel outside of its maximum bounds. Since it’s happening when jogging your laser, check to make sure to the jogging distance you have set in the ‘Move’ window is not excessive, or even one jogging command could be too far for your laser to physically travel.

When working with a rotary, you may also need to temporarily disable ‘Soft Limits’ in your laser’s firmware, by going to ‘Edit’ > ‘Machine Settings’ > ‘Homing and Limits’ and toggling the ‘Soft Limits’ switch off. You can also do thatPreformatted text by entering $20=0 in the ‘Console’ window. Be sure to toggle the switch back on, or enter $20=1 when you go back to flat engraving.

Thank you very much for your answer. Last night, a friend of mine made me enter a reset command and it’s working now. I’ll keep in mind the infos you gave me. Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.