Ortur Y axis rotary roller

Are there any changes to the setting in Lightburn I need to make to use the Ortur Y axis rotary roller.


Hi, I have a Ortur Master 1 laser engraver, it works well with Lightburn and has done for some time. I have just added their Y-axis rotary roller jig, connected the Y axis lead as per their documentation., however when it comes to the operating it something appears to be going wrong. It will not go to the home position when requested, it almost seems that the working area has been greatly reduced! it seems to have a mind of its own.
My question is: is this rotary jig only suitable with using the manufactures supplied Lasergrbl software of are there some setting changes to be made to my preferred Lightburn.

Thanks in advance.

The answer is no. LightBurn will control the movement of your rotary once you have it configured correctly. Use the ‘Tools’→’Rotary Setup’ menu to set up the rotary device step counts and job size, and enable the rotary toggle. Share more technical information about the rotary and its configuration so others can chime in on recommendations for the correct numbers.

Edit: Sorry. :flushed: I mean what @LightBurn said. :slight_smile:

I’m not certain I have Y-axis rotary work done for gcode based controllers. The ones we’ve supported so far all have a dedicated rotary axis. It’s on my list to investigate this to see if work needs doing, and figure out what’s missing.

Rick / Oz Many thanks for the quick reply, I now have the Ortur Master and rotary roller working with Lightburn however, when doing a simple text engraving with the Y axis dims of 90mm and the X at 15mm (as seen on the software) in fact what was engraved was the Y being 90mm and the X being 105mm…….
I checked the settings for dia of work piece/ roller size and circumfrence all were correct.

An further help would be appreciated.



Have you configured the “mm per rotation” value in the Rotary Setup in LightBurn? The software needs to know how many mm along the Y axis corresponds to one complete rotation of the rotary. If that isn’t set properly, nothing else will work.

Thanks Oz…Rotary problem sorted, thank you.

One more problem, I have just installed the latest upgrade 0913 and now I have an error 5 message
any ideas? as the machine will not move….Ortur Master and MacBook pro.


GRBL Error Code Description ~ 5 Homing cycle is not enabled via settings.

Oz, I forgot to mention the rotary roller was removed during the update. The machine was back to standard.


Salve, anche io da poco ho preso asse rotante Ortur, configurato in strumenti il tipo e le dimensioni (diametro rulli 21 mm - diametro oggetto 53 mm - mm di rotazione 150 è corretto?), abilitato il tasto “abilita rotazione”, ma praticamente la macchina non risponde ed il programma LightBurn va in crash… ci sono cose da fare o che non ho fatto bene?
Grazie per le vostre risposte

Hi, I too recently took the Ortur rotary axis, configured the type and dimensions of the instruments (roller diameter 21 mm - object diameter 53 mm - rotation mm 150 is correct?), Enabled the “enable rotation” button, but practically the machine does not respond and the LightBurn program crashes … are there things to do or that I have not done well?
Thanks for your answers

Capito il problema… cavi incrociati!!! :roll_eyes::roll_eyes::roll_eyes:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.