Ortus X and Y position always 100mm off

Hi,
I got a brand new laser engraver, and still testing out/familiarizing with the Lightburn software.
I try to key in 200mm by 200mm then hit move, and the head moves to 300mm X by 300mm Y. Or I can just try the location function to click on 50mm and 50mm within the 400mm by 400mm work space, it moves to 100mm.
This machine has a home limit switches. Do I have to modify any configuration on the application or the machine is defective?
Thank you.

@OrturTech will help you

1 Like

thank you.

can you install LaserGRBL and make tthe same test? just to see if there are software or hardware issue

yes, that’s what I will do tonight. Thanks.

I verified that my new Ortus machine XY movement were off in both LaserGRBL and Lightburn.

  1. I jogged (10mm) incrementally from a home pos. all the way to the machine max working spec (400mm by 400mm). Jogging 10mm, the head moved to 12mm mark on the frame, and this offset movement got larger as the head moved further from the Home position.
  2. Both applications reflected a correct position as requested, but the actual position of the head was off. ex: I asked to go to x200 and x200, the software display current position as x200 and x200. But the head physically moved to close to x300 and x300.
  3. When clicked on the Home button, it moved/hit the limit switches, and the current position showed x0 y0 correctly. The head stopped at x0 y0 mark on the frame.
  4. Interestingly, the test engraving came out good as long as the design was w/i the spec working area.
  5. I wanted to utilize its 400mm by 400mm working area and tried to engrave a check board pattern on the plywood (I mounted the machine on a piece of plywood) for ease in placing item to be engraved.

I submitted a ticket to Ortus tech support already. Will see what they can help.

Anyone has run into similar issue?
Thanks.

Ticket Transcribe
Greetings

Sound like you have an offset on your machine firmware
Do this for me, in order and exact please

connect to lightburn, in console type
$RST=*
press enter. Machine will respond with MSG: Restoring defaults
Tap reset button on motherboard
Download, unzip and follow PDF instructions to update firmware
https://ortur.tech/firmware/OLM_Series/OLM2_PRO_S2_Firmware_Release_1.87.zip

It should resolve the problem

Sorry but is useless to call for Ortur support, you only need to calibrate your axis, in LB click on edit then machine setting, in there you will find a Button called calibrate axis, click on it then choose an axis X for example, and, if i remember well, in requested you digit 10 and in obtained you digit 12, then write and repeat all steps for Y axis

Do you think is an offset and not a miscalibration of axis?

Two sets of very bad advise
a) yes he should get in touch with ortur support always, That is why i am here.
b) calibration is NOT necessary ever, if it “is” then something else is wrong upstream

1 Like

Thank you very much.
$RST=* did resolve the issue.

I also reply to you on Ortus ticket.

Fantastic news
On time do update firmware to stop it happening agian

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.