Out of position images. Consistently. Redux

I have an issue that I was hoping someone might have some ideas on how to fix.

When I am cutting or engraving images, the more complicated they are, the more parts of the image are out of position.

I have seen this mentioned before, either here or on FB, but now I can’t find anything on the subject.

I would have thought it was a loose belt issue, but the problem is more or less consistent.

It almost seems as if the info is sent to the laser in blocks and the blocks are out of register in relation to each other.

Any thoughts or help would be very much appreciated.

Thanks!

How does this look when you use the ‘Preview’?

Exactly like it should…

Assuming that the rails are clean, nothing binding, etc, I’m going to go with excessive acceleration when traveling between groups to be engraved. I can’t remember what ruida calls it without starting the machine and looking, but it’s essentially “whitespace acceleration”.

My ruida machine was hopelessly optimistic on acceleration and produced out of alignment stuff like you are showing. Try turning down 20% or so and see what happens.

Idle acceleration is the setting on Ruida.

Yes! that’s it. Idle acceleration.

Great, now not to sound too stupid. Can you tell me where I can find that?

I took a look scrolling through the menus on the machine, but I don’t see anything like that.

With the laser plugged into LightBurn, go to Edit > Machine Settings. Make your change and click “Write” to send back to the controller. Avoid the stuff in the “Vendor Settings” area in the bottom unless you understand what it does.

Awesome, thanks. I just lowered the number from 2000 to 1600 (20%). I will give it a shot first thing in the morning.

Thanks again.

How large is your machine? 2000 is relatively low as it is. My 700 x 500 red/black machine used 6000 (it shipped with 10000, but that was too high). If your machine is significantly larger it will have more mass, so that could be the difference.

No, it’s smaller. Its a 4060. But I lowered it, and it was almost perfect.

But, I just went to lower it a tiny drop more (to 1500) and it showed as being at 2000 again. Is there a way to make the controller remember it or will I have to reset it whenever I am doing “harder” jobs?

Did you do this?

Yes. I clicked on write. It did it, and then I clicked on save (or whatever the option is) not cancel.

So here it is. I did it, saved it, reopened the window a minute later, and it’s back at 2000.

When%20Reopening%20the%20window

Click “Write” not “Save”. Save is not completed yet, but will eventually be to store the settings to disk as a backup. “Write” commits anything you’ve changed to the controller.

If it’s reverting, that’s very odd - I haven’t seen that before.

This is a UI bug. If you don’t click or TAB input focus off the field you’ve just edited before clicking WRITE, the value you typed is ignored. I have this problem, and I also use OSX.

I suspect this is a platform specific issue, like the un-intuitive handling of trackpad gestures, which is driving me crazy.

Thanks, I tabbed through it, and it seems to be stored now. Thanks very much.

This I can fix - it’s the first I’ve heard of it, but it’s easy enough for me to pull focus away from that control when Write is clicked.

That’s something that will get changed, but it’s going to require a rewrite of all my view management code. I’m not sure if it’s OSX, or the Qt framework, but I don’t get access to the events for zoom & pan, it just moves whatever scroll area is attached to your window. I don’t have one, so I’ll need to add that, and recompute it constantly as the zoom level changes. It’s a decent amount of work in a very low-level part of the rendering code, to let one platform use two-finger gestures - it’s not the highest priority.