Over-burn at End of Pass

I’m getting an over-burn (if that’s the right term) at the ends of each pass.
I read in a closed thread to turn the min power right down. It seems mine is greyed out and I can’t adjust it. (Probably a good noobie reason for that.)
Also, the post had advice to turn off “Cut Through” but I’m unable to find that.
Attached are pics of the project in Lightburn as well as the finished burn on MDF showing the issue at the top & bottom (vertical scanning).
5.5w diode

Turn on overscan. This makes the laser continue to move past the edges of the image, meaning that deceleration mostly happens with the beam off.

Why vertical scanning? That tends to be significantly slower, as most machines have more mass in Y than X.

Thanks Oz,
I’ll try overscanning again but I’m sure I had the same issue there.
Vertical scan: I normally scan 45deg but tried vertical so I was certain it was the end of the pass and that the over burn was transferred to the Y axis.

If enabling overscan didn’t fix it, you just need to increase the amount. If your machine accelerates slowly, or you’re using GRBL-M3 (which does not vary power with speed) you will need a higher overscan amount.

I just output the G-Code and yes, it appears I’m using GRBL-M3. 1.1e.
Is that recommended or not?
Mine is a cheap chinese 5.5w diode, very similar, it would appear, to the Elekslaser.

It’ll work - 1.1f gives slightly better control, but with overscan enabled you likely won’t notice a difference.

I just tried it with 2.5% (3.14mm) over scan. But no improvement at all.
I’ll try doubling that value to see if it makes a difference.
In the video linked here you can definitely see the laser power off during the over scan but it looks like the damage has already been done by then.

You haven’t shared any settings - if your acceleration is low and you’re using GRBL-M3, you’ll need a considerable about to get rid of that edge burn.

I don’t know whether 800mm/sec^2 is low or not.

Connected COM3 115200

Grbl 1.1e [’$’ for help]


$0=10 Step pulse, microseconds (10)

$1=25 Step idle delay, milliseconds (25)

$2=0 Step port invert, mask (0)

$3=5 Direction port invert, mask (0)

$4=0 Step enable invert, boolean (0)

$5=0 Limit pins invert, boolean (0)

$6=0 Probe pin invert, boolean (0)

$10=1 Status report, mask (1)

$11=0.010 Junction deviation, mm (0.020)

$12=0.002 Arc tolerance, mm (0.020)

$13=0 Report inches, boolean (0)

$20=1 Soft limits, boolean (0)

$21=0 Hard limits, boolean (0)

$22=1 Homing cycle, boolean (0)

$23=3 Homing dir invert, mask (0)

$24=100.000 Homing feed, mm/min (100.000)

$25=1000.000 Homing seek, mm/min (1000.000)

$26=250 Homing debounce, milliseconds (250)

$27=1.000 Homing pull-off, mm (1.000)

$30=255 Max spindle speed, RPM (255)

$31=0 Min spindle speed, RPM (0)

$32=1 Laser mode, boolean (1)

$100=80.000 X steps/mm (80.000)

$101=80.000 Y steps/mm (80.000)

$102=80.000 Z steps/mm (80.000)

$110=4000.000 X Max rate, mm/min (5000.000)

$111=4000.000 Y Max rate, mm/min (5000.000)

$112=6000.000 Z Max rate, mm/min (5000.000)

$120=800.000 X Acceleration, mm/sec^2 (800.000)

$121=800.000 Y Acceleration, mm/sec^2 (800.000)

$122=5000.000 Z Acceleration, mm/sec^2 (5000.000)

$130=590.000 X Max travel, mm (400)

$131=495.000 Y Max travel, mm (300)

$132=200.000 Z Max travel, mm (200)

Does anyone know if 800mm/sec^2 acceleration in X & Y is too much or not enough? Or should I be flashing to 1.1f?

It depends on the hardware, but yes, 800mm/sec^ should be ok

That depends entirely on your machine, motor driver current and voltage, stepper strength, and so on. If you increase the number and start to lose steps then it was high enough. :slight_smile:

GRBL 1.1e does not do great with power ramping, so 1.1f is better. On the other hand, neither will fix edge burn if your acceleration is too low and you aren’t using enough overscan. Just make the overscan setting higher. The defaults are arbitrary so don’t assume that if you tried 2.5% that it doesn’t work. I’ve seen it set to as high as 50% to get rid of edge burn on some systems.

Thanks guys. It’s the not knowing where the boundaries for testing start and finish. ie. With 2.5% being default I would never have entertained going anywhere near 50%.

I actually have the same with my ruida which should have overscan by default?
this is happening with 45° and 15° scans at 300mm/s

Ruida does overscan in hardware, but only along the axis, not at angles. I can’t easily add overscan moves - I’ve tried, and the controller rejects them. You’ll have to adjust min-power to get the look you want.

I don’t recommend using angled moves on DSP controllers for anything other than coarse / artistic fills. They’re not designed for it, and don’t special case them like they do for on-axis scanning.

Going back to the pic in the original post, how do I make “min power” accessible? It’s greyed out.

You have a GCode based controller. Min Power for you is only available when using grayscale engraving, as the power value to use for white pixels.

Ah, that explains why I have had it before.
Thanks Oz. :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.