Over burn on some passes of fill, but not all

I was testing my laser on some anodized aluminum to see how that would work out and I got some strange artifacts, I’m not sure if it’s software, hardware or something else, but figured I should get some opinions from more experienced folks.

In the engraving there are areas where the laser appears to have not turned off and instead continued burning until it reached the end of the overscan area around the image (one example is highlighted above in yellow), it does seem to have turned off consistently at the end of the overscan though.

The burn was done by sending directly from Lightburn to the laser via the USB-Serial link.

I’m not sure if this is just a missed command in the command stream, a problem with the Gcode itself or the laser controller not turning off for some reason, though I doubt that last one because of how consistent it seems to be.

I haven’t tried exporting the Gcode and running it directly on the printer, I ran out of time for today, but I’m thinking of giving that a shot to see if it’s something getting lost in the command stream. Is there a way to pull a complete gcode log from Lightburn? I’d like to see if there are any missing acks in the stream that would indicate something was not received properly.

My machine is an i3 clone 3D printer running Marlin 1.1.9 with Lightburn running on Linux Mint 19.

If there was a missing ack, the job would not have completed. I have actually seen this issue before with Marlin devices, but it was a long time ago, and I can’t recall what the fix was. It’s not overscan - There are a couple in the first ‘n’ in Techno as well.

1 Like

I’m actually working on a better, larger format machine that will be running GRBL instead of Marlin; I rigged up the i3 with the laser to see if I liked laser engraving and if the cheapo diode lasers were any good before committing to a better machine. I expected there to be some drawbacks to pressing Marlin into service as a laser engraver, this sounds like a good excuse to start work on the new machine!

If you happen to recall what the fix was I’d love to get this working properly, but in the meantime it certainly works well enough to experiment with, and seems to work fine in vector modes, just not for raster.

Thanks!