Point 0 does not match at start

Hi. I have a problem and I think it is software configuration, when I indicate an origin point in lightburn, this when it starts it does it 2-3mm to the right where I indicate the starting point, can I adjust this so that it starts where I mark The origin?

I leave illustration image


I think you misunderstand what the origin point means - it represents where the laser is relative to your design, and that’s all. For example, there’s no possible way for this file to cut starting from the green origin dot:


It has to move somewhere else before it starts cutting.

On this design, it would be possible for it to start on the green dot, but if I have “inside shapes first” enabled then it has to do the inner rectangle before the outer one:


… so again, it would not start on the green dot, but the job would be positioned correctly anyway, so there isn’t a problem here. Are you just trying to make it start cutting from a specific part of the cut, or is it placing the work incorrectly?

It only happens to me with Lightburn, so I understand that it is some configuration. I know that it starts with the inner part and then the outside, but if I only make a square and select the origin point, as I say, start 2-3mm to the right to cut that square and not at the origin point that I select.

For example, I have the square of the image, I mark the point of origin on the machine where I want it to start and it should start there where I indicated it and where is the green point, right? Well, it does it 2-3 to the right
I have selected to start from user source in job settings

What type of controller are you using? Your profile says ‘K40’ but that gives no useful information to help you solve controller issues.

I am using a MiniGerbil that goes with grbl

So you’re saying that if you just draw a rectangle like this, move the laser to a spot on the bed and press Start, that it places the design 2 to 3 mm to the right of where your laser head was placed? Did you enter a ‘Laser Offset’ value in the device settings, maybe?

Edit > Device Settings, Laser Offset:

Yes, I move the head to an area, I mark the origin point in lightburn and when I start the work, the origin point marked 2-3 mm moves me to the right

I have the Off-set turned off as shown in capture.

I edit

Could it be because I select the user origin at the starting point and I must choose to start from the current position?

Attached capture of how I have it configured


Type $# in the console and press enter, then copy the text it prints back here. If your G54 line isn’t just zeros, that’s possibly the reason.

Well it’s not just 0, so those 3,000 that it indicates 2 times means the 3mm movement that I have assigned, right? How can I change it?













Those numbers means it’s shifted 3mm right and up. In the console window, type:

G10 L2 P1 X0 Y0

That will clear the offset.

Wow, amazing but it was that parameter. It is already solved and everything to 0.

I find it strange that it only happened with Lightburn but it is already solved !, thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.