Poor start quality at lower power settings

My CO2 laser while doing a scanning offset baseline test I noticed at lower power settings the laser is slow to get a full kerf. It looks like it is slowly ramping up. The other end of that mark looks good. With incremental increases in power the starting point gets better, but not a perfect full kerf to start. Do I have a software solution or could it be a hardware problem? both?

Can you attach a photo please?

To help diagnose the issue please go to Cut Settings, and disable ‘Bi-directional fill’, and then run the test again taking note of which direction the cuts start and finish. Then with a pen draw an arrow indicating the cut direction.

Which are? And the increments?

How fast are you doing this?

Lacking evidence at this point. The Ruida computes and applies the overscan needed so when doing a fill operation there is no need to ramp power as the head is at speed by the time it reaches the area it needs to lase.

Overscan adjustment in Lightburn is purely a way to nullify the backlash that exists in any mechanical machine. This is also adjustable within the controller, most don’t adjust here as it’s kind of nebulous for people to find. Either way, pick one of the two for adjustments.

If this is a new issue, I’d think the only case would be a laser power supply (lps) or the tube itself. The response time of the lps could be too slow… I know of no real way to check this, as a user, especially in this situation.

@NicholasL is correct – a photo would be great. Using a large interval it also becomes more visible.


I’ve added pictures. 1 direction and bi-directional with speed and power

Pretty clear difference when you turn off bi-directional scanning…

This appears to me as tube/lps connected.

An lps has to respond to 90% placard voltage in <=1mS if it’s not getting to voltage/current quick enough it could cause this…

I don’t know how the controller could influence this.

Good luck


Thanks for the info.

1 Like

Thanks for the photo, I see what you mean.

The line you drew in pencil… is that parallel with the right hand edge of the fill box? Was that at 400mm/s speed?

Looking at the 45%@400mm/s fill closer, there is a slight taper at the line start (a) which is pretty normal, then at (b) the line starts again heavy then settles. Am not sure about (c), it looks like a slight fade-out (but that makes no sense to me) so could be just an optical illusion or material inconsistency since it’s not obvious in some of the other pictures.


The longer taper at lower powers, and hot starts above 45% - I’m guessing are due to a larger than average laser tube (do you have the 150W?) . I don’t think there is any software setting that would help.

Did you enter and enable your Scanning Offset Adjustments yet?.

Please add a ‘Line’ sublayer in order to lightly etch the outline of the fill box so we can see where the fill starts and stops compared to the vectors.

When I applied the scanning offset adjustments to a previous project I got double images. As you can see in the word test is readable. Once the offset adjustments were applied you can no longer make out the word. I spent some time on the phone with Laguna yesterday and they were not much help. Bad tub? of something else. I have seen several you tube videos where people with Co2 lasers are making the adjustment and they look great. The big difference is their lasers seem to have a very clean starting point. The videos were people using OM Tech, Tunder, AEON and even a homemade one from Australia. Laguna was going to give me a call back today. I feel like it could be a hardware issue.

Right, so please confirm - you can make and enable a scanning offset adjustment (as described in our documentation) and tweak it until the left and right sides are neat, but when you decrease or increase the power the adjustment appears to no longer work?

That is not a normal issue, but in that case you would need to make the scanning offset calibration entry correct for the speed and power level that you would be most often using. For example, considering your first pic, if you were going to be doing a lot of engraving at 400mm/s 35% power, then you would have a 400mm/s entry and adjust the ‘Line Shift’ value until the lines (ends and starts) align for a test fill at 35%.

Problems would arise though when running a lighter and darker fill in the same job so you would need to switch to single direction fill for that, which will look good - but take twice as long…

Once the offset adjustments were applied you can no longer make out the word TEST. I am thinking that the voltage to trigger the tube is not sufficient to make a nice round burn to start at this low power setting. Looking at that hypothesis I have figure out where that voltage comes from and now how to test that or what controls that. Laguna sent me a text after waiting all day for the call that he was out for the day. Maybe today I will get solid troubleshooting from them. holding my breath.

It could also just be a weak tube. $$

I spoke to a laser tube specialist and he suggested that i was asking too much from a 150W tube at that speed. At reduced speeds the lower power settings are better. So I will change how I engrave using slower speeds at lower power setting. I learned a lot today.

Basic response time of the lps issue…

Keep in mind that a regular dc excited tube has a trigger voltage. An lps has a response usually specified as <=1mS for 90% placard voltage.

An example – assuming a complete lase within 1mS, if your speed is 1000mm/s, you can only toggle the tube on/off every mm for a dpi of 25.4… If you drop the speed in half to 500mm/s the dpi is now 50.8. Even further down at 250mm/s you can double it again for 101.6 dpi… Not too optimistic is it?

I don’t remember how small the boxes you were engraving are physically, but I’m pretty sure you’re seeing the tube start and ramp up into a lase. You can measure them and see how long it takes… would be interesting…

Of course all of this is assuming the tube is actually triggering and lasing at the 90% voltage… other wise it could be longer.

Glad you have it worked out…


Sorry - it wasn’t clear to me which of the pictures you uploaded actually had scanning offset applied and which did not.

If I’m understanding you correctly now, …scanning offset has been calibrated and enabled the whole time, please ignore my last post about tuning the scanning offset.

Regarding the word ‘TEST’;

If the image below does in fact have the best scanning offset applied and enabled for 400mm/sec, then presumably when the scanning offset is disabled the “outline” of the text (as indicated by the red line below) will become jagged making the text illegible? - We don’t have a picture of that yet, but that makes more sense with what you are saying.

The longer taper / poor start quality at lower power seems to occur at the edges more than the middle - suggesting it is only happening after a longer period of the tube being idle.

If this is the case, please run the attached ‘Test.lbrn2’ of several 40mm x 10mm rectangles [400mm/s, 25% power, 0.5mm line interval], as this will help to accentuate the extent of this problem in three different ways;

(1) Highlighted in green, the first 4 shapes from the top have a bi-directional fill, so I would expect the edges of these inside shapes to become progressively more jagged as the inside shape increases in width.

(2) Highlighted in yellow, and a single-directional fill (hopefully from left to right), the 1mm wide bar should more or less disappear, but the edge of the main fill in that same area will improve, since the bar should have effect of a ‘tickle’.

(3) Highlighted in pink and also a single directional fill, is a triangle which is designed to produce 40 fill lines in total from 0.1 to 4mm in length with the idea to help quantify the extent of the delayed response by observing the number of fill lines that disappear from the top of the triangle.

Test.lbrn2 (7.9 KB)

Please note: The idea of the above test is not try and resolve the issues here, but to visualise and measure them. Ideally, if somebody else here has a 150W tube it would be very useful to see a comparison of the result. At 400mm/s I would not have expected the start of the burn at the edge of the fill box to be quite as weak as you are experiencing at power levels below 40%.

As a side note, it seems to me that it could be possible to compensate for certain characteristics of a longer tube using software, since it could be possible to use software to ‘tickle’ the tube behind the scene immediately prior to a ‘cold-start’ engraving line.

Laguna is going to send me a replacement tube as they feel it is very weak. As for the test Nicholas, I will increase the power so everyone can see. The issue has been output at lower power setting. Thank you for the time you have given my issue.