Port failed to open- already in use? (not a USB issue)

Hi, I know there are a couple of other people who have already asked this question but I could not find a solution for the issue that worked for me. LightBurn gives me this message whenever I unplug and replug the USB cable, as well as when my computer restarts or when I don’t use the laser/LightBurn for a couple minutes or hours. The only thing that works is restarting the laser completely by restarting the Duet board it is connected to which, although I am glad that there is at least a temporary solution to the disconnection, I would rather have a permanent solution so I don’t have to recalibrate the laser every time just because I have to restart the machine. I see the COM port in Device Manager, so I don’t think its a USB issue, and the laser itself works fine, so I’m not sure why it keeps disconnecting every use.
I do however get a “Bad command: $I” and “Bad command: $H” message anytime LightBurn connects to the laser, so maybe that might give some insight to the problem because I don’t know what those messages mean either. The machine uses a Creality Laser Module and a Duet 3 mini +5.
Is it possible there might be an issue between the Duet and LightBurn?
Any help would be appreciated, thank you.

I think @JoeSpanier is the only one on staff with a Duet Board.

I’m not familiar with the Duet but, when it restarts, what exactly requires recalibrating? Do adjustments to settings not persist when the controller is power-cycled?

In GRBL, $I generates a System Information report and $H is the homing command.
If you’re seeing these messages in the Console window in LightBurn - the engraver is complaining because it’s seeing classic GRBL codes. You can turn off the AutoHome on startup in Device Settings in LightBurn but the disconnect is likely the expectations of the control board.

Likely a settings issue. Hoping Joe says something.

Which Firmware are you running on the Duet 3 mini +5?

The recalibration is just with homing the three axis and leveling the bed for the laser head which needs to be repeated when the machine restarts. I believe it is the RepRapFirmware that Duet boards run on.

We don’t actually support a connection to RepRap firmware or duet at the moment. I’m hoping to change that soon.

As for the disconnect the usual steps come into play. Make sure the cable is of high quality and preferably has ferrites on both sides. Make sure everything has good grounds and usually these disconnects can happen because of static.

Are you sending direct from lightburn to the Duet and not from Duet Web control?

The Duet Web control is what I use to calibrate the machine but Lightburn is what I direct projects from, yes.

The “Bad command: $I” and “Bad command: $H” message is because those are homing and reset commands in GRBL and are not what Duet is expecting.

I am guessing something with COM port is not being closed appropriately when the cable is disconnected or your computer restarts. Honestly though both of those situations are times to rehome your machine anyway as it can loose track of where home is in those instances. Duet is slightly more stable for these because it can run without LB connected but when you are serial sending over USB it’s less stable that it is if you are just running the jobs over web control.

I just tried sending from LB for the first time and while it does work (much better than I expected it to honestly) we still cant say we support it at the moment. It’s a target in the future for sure though.

ok, thank you so much for your help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.