Port Opened, No connection


I just received a laser engraver for Christmas, and I would love to be able to use this software. Lightburn couldn’t auto-detect my device, but I know it is running Grbl 1.1f, so I tried manually connecting. It appears to be doing SOMETHING, but the port just stays open and I can’t actually connect. I’ve pasted the debug log if it helps… Also, I’m running an Arduino Nano 328p if that helps.

11:01:49.517 D: “LightBurn 0.9.09” “Sat Dec 28 2019”
11:02:06.051 D: Clipboard data present:
11:02:06.051 D: (“application/x-qt-image”)
11:02:28.611 D: Clipboard data present:
11:02:28.611 D: (“application/x-qt-image”)
11:02:33.885 D: “LightBurn 0.9.09” “Sat Dec 28 2019”
11:02:53.533 D: Clipboard data present:
11:02:53.533 D: (“application/x-qt-image”)
11:03:10.711 D: Clipboard data present:
11:03:10.711 D: (“application/x-qt-image”)
11:03:14.776 D: “starting” busy: false state: 0
11:03:14.776 D: Enumerating ports:
11:03:14.782 D: Port: “COM1”
11:03:14.782 D: Valid Candidate: true
11:03:14.782 D: PID: 0 VID: 0
11:03:14.782 D: Manufacturer: “(Standard port types)”
11:03:14.782 D: Description: “Communications Port”
11:03:14.782 D: System Loc: “\\.\COM1”
11:03:14.782 D: Serial: “”
11:03:14.784 D:
11:03:14.784 D: Port: “COM4”
11:03:14.784 D: Valid Candidate: true
11:03:14.784 D: PID: 29987 VID: 6790
11:03:14.784 D: Manufacturer: “wch.cn
11:03:14.784 D: Description: “USB-SERIAL CH340”
11:03:14.784 D: System Loc: “\\.\COM4”
11:03:14.784 D: Serial: “”
11:03:14.784 D:
11:03:14.838 D: Found port: PID 29987 VID 6790
11:03:14.838 D: Manufacturer: “wch.cn
11:03:14.838 D: Product: “USB-SERIAL CH340”
11:03:14.838 D: Name: “COM4”
11:03:14.841 D: Port open succeeded
11:03:14.879 D: “starting” busy: false state: 0
11:03:14.880 D: Clipboard data present:
11:03:14.880 D: (“application/x-qt-image”)
11:03:15.865 D: “Attempting to connect” busy: false state: 1
11:03:15.865 D: “Connecting…” busy: false state: 1
11:03:15.866 D: O: “47300a”
11:03:17.094 D: I: “0000000000000000000000000000000000000000000000000000000000000000”
11:03:17.106 D: I: “0000000000000000000000000000000000000000000000000000000000000000”
11:03:17.115 D: I: “0000000000000000000000000000000000000000000000000000000000000000”
11:03:17.118 D: I: “00000000”

The device seemed to connect, but sent all zeros. That could be an incorrect baud rate setting. Have you ever connected to this with any other software?

I’ve been able to attach it to T2Laser, as well as the cheap Chinese program (Engraver Master).

From what I can tell, the Baud rate is 9600…doesn’t seem to be a setting for that rate within Lightburn…unless I’m missing something.

I could go that low in LightBurn I just didn’t think anyone ever would - the performance would be abysmal if you ever tried to do anything other than simple vector cuts or engraves. I’ve added 9,600 and 19,200 baud to the next release.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.