Position error on Y Axis only

I am using an XCarve as my machine with a 7W Jtech laser. I downloaded the free trial and got started immediately and actually lasered two projects just fine. Set my parameters and the machine went exactly where it was supposed to every time. Now my issue is that on the X Axis it goes exactly where it needs to but on the Y Axis it goes the complete opposite direction, essentially working outside of what it knows as the “work area”. I’m not sure what’s wrong or how to fix it as it worked great before.

As a follow up, I just ran a design using LaserGRBL and it worked fine. Something in the software seems to be tell it to go that way.

Check that you have the appropriate workspace offset applied for the XCarve to put the 0,0 location in the front left. Read the 3rd point in the ‘Short Version’ here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

The front left is where it goes every time. The shouldn’t be an offset as there wasn’t when it was working properly. It doesn’t make sense to me why one axis works fine and the other doesn’t. If it was an offset issue wouldn’t both Axis be moving in the opposite direction?

Nothing? I did 11 projects on the first day without issue. Now I have issues and can’t get a response back. There is no tech support number to call, just have to sit here and wait for a reply as my customers wait as well. I do not think I will purchase this program, I would rather spend more for a company who will answer questions or at least have a tech support number where they can walk me through issues. Seemed like a very good program at first and I was about to purchase it on the first day. I’m glad I waited further into the trial. Thanks anyway.

I’m sorry but I was moving yesterday, shuttling things between a hotel, storage locker, and our new home.

Type $# into the console to see if you have a workspace offset enabled. If you don’t, that’s a problem, because it’s required for XCarve and Shapeoko machines. (It will be in the first line, G54, and should be X-812 Y-812, or whatever values represent the size of the workspace of your machine)

You said “the front left is where it goes every time” - Do you mean that this is where it’s heading when you try to start a project?

LightBurn is one developer (me) and two support staff, and they don’t have experience with XCarve systems. I’m sorry you had to wait a day, but we’re human.

Gotcha, I am a one man show myself so when customers are waiting work just piles up and gets overwhelming. Especially in this time of political unrest and I’m a gun manufacturer, Beto the Fako has been good for business.

When I say that I always start at the front left that is where I have my laser when I turn on the program and controller so that becomes my absolute zero. It worked before but now it moves outside the work area and when I tell it to go back to absolute zero it goes to X 0.45 Y 1.50. I typed in and the offset is G54:0.4498,-1.5000,-0.2531. The XCarve I am using is the 500X500, so I have my work area at 250X250. I attempted to use the offset directions as outlined in the link you sent but that made my machine go absolutely crazy to the opposite corner (back right). My laser is mounted to the front of my spindle mount so when I set the machine I have the laser where I want it to start from (absolute zero). No matter what I start from (absolute, user origin, or current position) it moves exactly the same way. Fine on the X Axis and opposite on the Y Axis but proportionally. For example if I wanted the work to start 20 cm into the work area, the Y will bring it 20 cm outside my work area. I’m trying to figure out why it worked perfect one day for 11 projects, then not work the next day.

I have 4 more ARs to build and got another order for two 1911s so the sooner I can figure this out the sooner I can customize them. If I can get the program working like it did the first day that would be awesome.

Do you have limit switches on the machine? If not, powering up with the laser at front left should work.

In Edit > Device settings, where do you have the origin point set to?

No limit switches and front left on the origin setting.

What does the software say when you click “Get Positions” after turning it on?

When it first comes on it’s zero across the board. If I let it run the full program it will end on X .45 Y 1.5 and it will use this as it’s start and end point from now on, I can jog it back to zero but it’s running as if those coordinates are the lower left corner. This remains true whether I start from absolute, user origin or current location.

That’s what your G54 offset is, so that makes sense. Try typing this into the console (and press enter):

G10 L2 P1 X0 Y0

That should clear the offset.

If you used your CNC software between now and the last time you used LightBurn, that’s probably what set it, and why you’re having issues. Some of these settings will persist in the firmware until changed, and LightBurn doesn’t set any of these, because they interfere with other software.

Ok. I did use it on my other XCarve (I have two) to engrave serial numbers. I cleared the offset and that seems to work. I will save that as a macro and use it when I go from one machine to the other. Thanks.

Worth a read if you haven’t already. https://jtechphotonics.com/?p=10204 Macro setup is covered near the top of the document. XCarve is discussed halfway down the page. :slight_smile:

I read that and used it to set up the first time. I think the issue was exactly what was explained, I ran a different job on easel then came back to lightburn and it threw my offset in a funky place. I have a 500X500 XCarve that I use with two lasers (one inside the spindle mount and one outside) and a 1000X1000 XCarve with the router only. I use the same controller for both, just swap the motor plugs. That may have had the consequences I just experienced. I am going to set one macro for the outside laser and one for the inside. Thanks for the link though, I’m actually going to save it this time and print it off.