Position shifting mid-job

I am not sure what could be wrong. I am running a multilayer single item that I have used the array function to create many of the same object. When I run the file it will get through part of the way through the batch and somewhat randomly shift the alignment about 3mm to the left. I have been beating my head against a wall trying to solve this. It repeats but not in any way that is predictable.

I am leaning towards something to do with the steppers and belts but for all I know it could be software. Each time I am there everything works fine, but when I leave I get the shift.

Please help

William

You likely need to either increase your motor current for X and Y or decrease your acceleration. You machine isn’t keeping up with the requested movement speed and skipping steps, causing it to drift out of position.
You can do both of these things from the smoothieware config.txt file on your C3D board. Just search for current and acceleration. I recommend changing them just a little at a time and retesting. Most likely it’s current… just increasing by 0.1, retest, then repeat if needed.

1 Like

Thank you for you helpful advice! Here are my settings:

# Stepper module pins ( ports, and pin numbers, appending "!" to the number will invert a pin )
alpha_step_pin                               2.0              # Pin for alpha stepper step signal
alpha_dir_pin                                0.5              # Pin for alpha stepper direction
alpha_en_pin                                 0.4              # Pin for alpha enable pin
alpha_current                                0.4              # X stepper motor current
alpha_max_rate                               24000.0          # mm/min
alpha_acceleration                           2500             # mm/sec²

beta_step_pin                                2.1              # Pin for beta stepper step signal
beta_dir_pin                                 0.11            # Pin for beta stepper direction
beta_en_pin                                  0.10             # Pin for beta enable
beta_current                                 0.6                # Y stepper motor current
beta_max_rate                                24000.0          # mm/min
beta_acceleration                            2500             # mm/sec²

I will increase alpha_current to 0.5 and retry.

I would have never known about these settings had you not mentioned them.

Thank you.

So I made the .1 amp adjustment as suggested with similar results. How far can I go and not be out of spec? I have added pictures to show the offset, note the unburned band in the hair that has shifted the burn to the left. Row 1 you can see it in the last position and in row 2 you can see it in the fourth position. As you can see the position in the process doesn’t seem to matter. Each picture is from a different row of the same burn project. The far left example is correct, reference, or ideal burn.

PS After looking at the pics it looks like the offset if both to the left and down in the second set…?

No expert here, but I would be curious about settings across layers.
The background ( text ) doesn’t appear to be shifting…

Gregory, thank you for your input! I am not sure what you mean by the settings across layers? There are three layers to this project: Layer one is fill which carves out leaving the ladies outline, and all the letters. Layer two is an image layer which craves into the ladies outline from layer one. Lastly which is not shown is a cut layer that cuts each out.

Is this the type of information you were wanting?

Just throwing this out there too, sometimes when I start up a burn it does this wonky thing where it tries to burn out of boundaries (as if the origin is set in some weird place outside the project), if I don’t do both framings first before I tell the project to play I can get this odd state. I share this as for all I know it might be related. Forgive me for being new and not understanding this all.

I’m really new here too, but I was wondering why one layer was shifting and not the other, and if the parameters were the same for all layers.

Me too, the first layer which is a fill layer never seems to have an issue.

@William_de_Sade Did not realize you were doing images…
So, Smoothieware can start to stutter and potentially loose steps when doing images at a very high rate like that. Are you using the cluster firmware or regular?
Cluster firmware is a special version for the C3D board that drastically speeds up sending a ton of small gcode commands like you need with an image, which LightBurn supports.
Even with clustering though, 250mm/s with a 0.1mm line interval is really pushing how fast it can go… note that with the regular firmware anything over 80mm/s and 0.1mm line interval would be way too fast.
So, if you aren’t using the cluster firmware, definitely do. The C3D docs should have you covered there.
If you are then you’ll have to slow down. There’s really nothing else to be done, it’s just a limit of how fast it can process the gcode.

2 Likes

Wow I had no clue I was pushing the envelope! Can you recommend a good source to understanding the bounders of the hardware & software settings?

Because pics seem to be worth 1000 words I have dropped pics of all my layers would you please advise if I am out of tolerance ?

I will dig into cluster firmware asap…

THANK YOU!!!




It’s a little bit involved to work out the actual throughput for GCode, but not horrible. Basically, normal smoothieware maxes out at about 800 instructions per second. At 80mm per second with 0.1mm dots, that’s your 800.

The simple math version is, 800 x (interval) = max speed.

So at 0.05mm dots, 800 x 0.05 = 40 mm/sec max

If you’re using Cluster mode firmware, and have clustering enabled, the numbers roughly triple to about 2400, so 240 mm/sec at 0.1mm dots, or 120 mm/sec using 0.05mm dots.

1 Like

Thank you Sir!

I tried clustering and that created an undesirable finish. Reading more about what Adam said I reduced my image settings to:

The result is somewhat improved but now I have misalignment in the other direction. I did not read your words in time to make the calculation of 800 x .051 = 40.8 I will try that tomorrow morning and report back.

I am guessing I am pushing the limits of my equipment with a DPI of 500?

Thank you,
William

Absolutely, yes - you’ll probably find anything above about 318 DPI is detrimental to the output quality, because the dots are roughly 0.08mm in size (maybe just a hair smaller, but you need to measure with a microscope). If you set the DPI too high or the interval too small, the output dots start overlapping, and it muddies the mid-tone shading a lot.

Thank you sir for your invaluable advice! I will play with the DPI this morning as well.

LightBurnOz

It’s a little bit involved to work out the actual throughput for GCode, but not horrible. Basically, normal smoothieware maxes out at about 800 instructions per second. At 80mm per second with 0.1mm dots, that’s your 800.

The simple math version is, 800 x (interval) = max speed.

So at 0.05mm dots, 800 x 0.05 = 40 mm/sec max

If you’re using Cluster mode firmware, and have clustering enabled, the numbers roughly triple to about 2400, so 240 mm/sec at 0.1mm dots, or 120 mm/sec using 0.05mm dots.

So far the slow down has eliminated the issue. You say smoothieware maxes out at 800 instructions per second, is there another way to speed it up besides the clustering which greatly diminished the quality (I don’t know why anyone would use it, maybe I have it poorly set) or can I use something other than smoothieware? The slow down to 40mm took my project into the 5 hour per 40 realm which is too slow for the volume I have to run.

Bump Please