Power control confusion

Cannot control power with Lightburn selection but test macro works fine.!

That is a wonderfully cryptic riddle, but not nearly detailed enough to be a request for help. We do not charge by the word here, so please describe your problem using lots of them. For example, “I have tried to make a series of lines using different power values, but they all fire the laser at the same power” or something similar that describes your problem in detail.


further explanation. Using the above g code program as a macro results in varying power levels, and current levels varify that. Using the first example, on Lightburn does not result in varied power levels also indicated on the current meter.


1 Like

What device profile have you chosen in LightBurn and what is the “S-value Max” setting in the Device Settings window?

Device setting is for smoothie with a cohesion 3D, K40 laser. The problem I am trying to describe is simply why when all things the same, does the power test macro work and change power settings accordingly but the powers settings in the cut menu don’t. am I supposed to save the file before? Doesn’t make sense.

Draw a small square, set it to “Line” mode at 100mm/sec and 100% power. Save the GCode and paste it as text into this thread.

Hope this is what you wanted

Screen Shot 2020-08-06 at 12.25.20|633x500](upload://p2TwFR6WunO7iaNS4mNpnA1zWnx.jpeg)

In looking ad comparing the power settings, the test code was specifying S01 as full power and lightburn shows S1000. Further ran power at 85% and gcode was S850. What does my cohesion board need in way of commands to set power?

Problem solved. Removed file: prefs.ini then reselected Smoothieware. Thanks for the help

You can also just delete the Smoothieware device from LightBurn and re-create it. What likely happened is you switched the profile from GRBL to Smoothieware, and it kept the S-value max (1000) from the GRBL profile. I think I have code in to prevent this now - which version of LightBurn are you running?

Thanks. Just upgraded to 0.9.14 yesterday

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.