Power of laser drops in LB

my laser power drops to nothing in LB only itd fie in T2 or lasergbrl ive got it set on 100% $30=255 all settings are correct but still rubbish and its a new board

Hi Andrew. As a simple test, can you save some GCode from T2 or LaserGrbl (just draw a square or something similar) and do the same from LightBurn? It should be easy to compare the two and spot what’s different.

If you draw a simple rectangle, set it to line mode, then click ‘Save GCode’ in LightBurn, it’ll ask for a filename. Save it as a .txt file, then copy and paste the text here. Do the same from LaserGrbl or T2.

LightBurn just emits GCode to the machine. Since you haven’t mentioned anything about the settings you’re using in each program, whether you’re trying to fill or cut, or really anything else to go on, posting GCode should get us there quickly.

all settings are the same in all 3 softwares but when i run in lightburn its very faint and poor quality, ive tried many settings in LB low high 255 - 1000, ive done my settings the same as a friend with same hardware and still its poor quality

We have about 13000 users at this point, with half of them using GCode based lasers without the same issues you’re having, so I have to assume for now it’s something you have set different on your system. I’m not trying to be cheeky or rude, but if it was just that LightBurn is bollocks and didn’t work, there’d be more than just you saying it. :slight_smile:

Post the GCode and I should be able to help you.

its working the dogs bollox for my friend so its a setting a laser or the control board doing something

Ok, that all looks reasonable. Your speeds are a bit slow, but probably not bad for a diode. Max speed is 4000 mm/min, or about 66 mm/sec. If you’re using the GRBL device driver, the board will automatically lower the power if you try to go faster than that. If you use GRBL-M3 as the device driver, it won’t do that, so that’s something to check.

Next up, post a screen shot of your window for Edit > Device Settings, and then post the GCode tests. Those will be the ones I’m most interested in. If you draw a square, and run it at the same speed and power in LightBurn as in LaserGRBL or T2, it should come out the same. If it doesn’t, then we should be able to figure out why pretty easily.

now im lost my speed is set to 72000 mm/m with power of 85% for doing a photo on a tile same settings my friend gets perfect results from


thats a photo but not with the settings i have now

Those are the speed limits in your GRBL device. $110 is the fastest your laser is allowed to move in X, in mm per minute. $111 is the Y speed limit, in mm per minute. LightBurn can ask it to go faster, but it won’t.

LightBurn, when using the GRBL device profile, uses a command called M4 (variable power). This means that the power output is adjusted as the speed varies, which results in more consistent burn. It also means if you ask your laser to go faster than it is allowed to, it reduces the power instead, to compensate.

If you use the GRBL-M3 device profile in LightBurn, it uses the M3 command (constant power) which doesn’t vary the power output as the speed changes, so you get dark spots on the corners if you burn a square, because the laser slows down for the corner, but doesn’t lower the power to adjust for the lower speed.

T2 and LaserGRBL both use the M3 command, so this could easily be the difference.

I assume you means 7200, which would be just under twice as fast as your laser is allowed to move. If you’re using the GRBL device in LightBurn, instead of GRBL-M3, it would reduce your power by about half. (72000 mm/min would be 1200 mm/sec, which is faster than a lot of industrial machines will go)

You can fix it by lowering your speed, or by increasing the speed limits in your controller. Depending on the machine you have, this might cause some issues, but might not. You’ve said nothing about the physical machine you have, so I can’t say if that would work or not.

the photo i sent the speed was set to 72000 settings from my friend … im going to kill my mate

7,200 would work. 72,000 would not. :slight_smile:

Both would try to move your laser faster than your settings allow it to move. 4000 is the maximum speed you can go, according to the settings in your controller.

that will be it then always a user error lol, ill give it a quick try now, ill let you know

All looks good now fingers crossed speed 1200

thanks for all your help

You’re welcome - glad we got you sorted.

Its still struggling for power when i use T2 its more clear and burns better, ive focused the beam to a smallest dot possible. also having problems getting it to start from where i want, i tried absolute coordinates it worked and then stopped working, tried current position but when it starts it moves somewhere else, ive made a grid board of 450mmx450mm to be accurate, but still cant get it to work, any ideas

Does your machine have limit switches, and home itself when it starts? If not, you’ll need to manually position it to the origin (front left) before you power it up, or it can’t know where it is. Absolute coordinates and user origin only work when the machine can report its position.

Current position should work, but be aware that current position just means “the green dot is where the laser head is when your job starts”. It can move somewhere else before it begins to cut.

For example:

If this is my job, the green dot shows where the laser head is assumed to be, relative to the stuff I’m cutting. The circle isn’t touching the green dot anywhere - it has to move to start cutting.

Read more about the origin modes here: https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md#coordinates-and-job-origin

When you say “T2 is more clear and burns better” that tells me nothing. Are you engraving lines or pictures? Can you show a snapshot of something to give an idea of what you mean by “better”?

Most likely you’re still trying to go faster than the machine is allowed to, and the controller is reducing the power on you. You can change this by clicking on “Devices”, then “Create Manually”, and choosing GRBL-M3 from the list. If you use the GRBL-M3 profile it will tell the controller to use constant power mode, which I think is what T2 uses.

  1. it now works with current position setting red dot in bottom left and it moves to where i place text and goes back after it finishes
  2. the power settings are as we discussed max 4000
    (i was using 1200mm/m at 100% for photo)
    LB is not as clear as T2

    machine is set to GBRL M3 profile

sorry its working with absolute coordinates not current position