Power output scalling issue

I have noted a vast discrepancy between what Lightburn is saying the % output power is and how much current is displaying on my mA meter (viewing the mA meter in a % frame of reference). Is there a way to scale this so when Lightburn says 10% I am getting 10% of my lasers output?

I do have my laser constrained via the physical inputs on the face of my K40.

I’m not really sure how the cohesion board is wired to the lps…

As far as I know, the standard K40 has a pot or a digital display to control tube current via IN of the lps… is yours configured this way?

:smile_cat:

Yes the digital pot, that is what I meant by constrained, that I am using the digital pot to stop it from over amping.

The two ways these are wired…

I’ll call your type with the dc voltage to the IN pin of the lps a K40 and the other a dsp, like a Ruida.

The IN terminal of the lps determines maximum current flow.
The L/H inputs to the lps are laser enable. L is low active and H is high active.

With a dsp type the pwm goes to the IN terminal determining the maximum current flow by the power percentage of the layer. This allows software to control the tube current.

When I ask for 50% power, I get a 50% pwm to the lps, continuous while the layer is running.

When the L input goes active, the tube will lase at 50% power (set by the IN value).


With the K40 style, the pot or dc voltage is feed to IN setting the lase current to that value… this is what eliminates the ability for software control of tube current.

The pwm goes to the H (inverted L), when it goes active the tube lases at the IN current setting.


Doing a line with the dsp type the tube lases continuously the entire length of the line at 50% power.

Same operation with a K40 type causes the tube to lase on/off at 100% power for 50% of the time. Averaging 50% power.

If you set your power to 50% and lase the machine, your meter will read 50% of the current you are passing through the tube…

If you lase your tube at 50% power in Lightburn and set your current with voltage control for 50% maximum current, it should do the trick…

Make sense?

:smile_cat:

No sorry!

Let’s start with definitions…

Ips (Independent Power Supply?)
IN (Input Terminal?)
pwm (Pluse Width Podulation?)
dsp (Digital Signal Processor?)
lase(s) (???)

I think once I understand these abrevations I might be able to make some sense, thank you for trying :slight_smile:

Sorry…

lps → laser power supply produces high voltage to excite the tube
pwm → pulse width modulation … usually controls power
dsp → digital signal processor based, such as the Ruida, Trocen …
lase → the act of lasing something… you tube must lase before it produces

The two red jumpers may not reflect how yours is wired.

The IN and L were the ones I was commenting on.

Do you have this type or another type of lps?

:smile_cat:

Thank you for this clarification, it really helps. Mine is similar but no jumpers. Do you need pics?

If it was working, then it’s probably ok, as long as you haven’t been re-wiring things. :crying_cat_face:

Did you try setting the 50% pwm and setting the mA meter to 50% maximum current?

:smile_cat:

So off the cuff I didn’t understand this and I haven’t had a moment to really try to wrap my brain around this. Currently I have the digital pot set at 48 which limits my output current to 16mA. With that set like this I have a tough time doing low power details. I can be have lightburn set for 1% and be pulling 10mA causing my Image burns to be more like fills then a laser kiss on the material. I end up taking the digital pot and bring it back to 18 to get that nice laser kiss say using grayscale.

BTW thank you for taking your time to work with me I really appreciate it

1 Like

It sounds like you might have a hardware issue…

If you have a voltmeter, you can measure the pwm output from the controller… it will read the set power (percentage) of it’s signal. These are ttl so it can go up to 5V and down to 0. 50% power (pwm) will read 2.5V…

If it’s working the next step would be the lps.

Most of these will not lase below about 10%. Are you trying to do that?

:smile_cat:

Sorry I have been away and have not had an opportunity to get back to this. I am very thankful for your help and I am eager to try this but it will likely not be till next week when I have time to get to this. Again thank you I really need to solve these issues and your help is appreciated.

~William

Ping - Ensuring this stays open

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.