Power Scaling, My 45w Laser is too strong lol

I might be in the wrong category if so please feel free to move this post…

My issue is that on my lowest software power setting my laser is too strong. It goes from too strong to off. If I use the lasers master power control (hardware) then I can reduce the strength of the burn. I was under the impression that is what the power control on the software did, was reduce the power range I set in hardware scaled between 0-100 in software. Can someone point me in the right direction? I would like to use the power settings in the software to gain the full range from my laser, if possible.

Thanks,
William

K40 and C3D board as stated in your profile?

There is often a current trim adjustment on the High voltage power supply. Please be careful and follow all the recommendations from the manufacturer.

If you can share your Config file for the C3D board I may be able to suggest the correct value for S-value max in Device settings for LightBurn.

Master Jedi, I will get you said file can you share more on what this S-Value Max is and where I can find information about it?

So I have looked over the Lightburn software for this configuration file and I am not sure where to find it. Your guidance would be helpful in locating where it is to complete your request.

Ahh, yess… I too am a nerd. It’s an old code - but it still checks out.
I look forward to seeing the plans at the base on the big screen.
This problem is smaller than a womp rat.
:smiley:

The config file ships on the SD card with your C3D board.
I’ll see if there’s a downloadable one there that I can make sense of.

The S-value Max is in Device settings in LightBurn. Common numbers for this are 255 or 1000 but anything is possible and allowed.

If the board is set for 1-255 for the scale and If LightBurn is set for 1-1000 for scale and if LightBurn asks for about a 300 on the next move it’ll be maxed right out. I’m thinking that this might be making this behaviour happen here.

1 Like

Is S value max a function for GRBL? I tried looking it up as I can’t find it. When I searched on the web the results were around someone using GRBL. I am lost, Sorry

Interesting, this is something that smoothieware does differently.

In this doc:
https://smoothieware.org/laser-cutter-guide

A search for M221 got me to here:

Supported G-codes

The following G-codes are supported by the Laser module :

  • G0 : Move without activating the laser

  • G1/G2/G3 : Move with the laser activated

  • Shift : The S parameter sets the current power of the laser, when it is activated, from 0 ( 0% ) to 1 ( 100% ).

  • M221 Snnn globally scales the laser power provided by G1 by nnn percent. So M221 S75 will scale the laser power to 75%.

  • M221 Rxxx : Set the PWM frequency to xxx Hz (Hertz). This specifies frequency, and not period, be aware and careful.

  • M221 P1 : Temporarily disable proportional laser power (as per the Laser_module_proportional_power configuration option, see its description for more details). This is not saved by the M500 command.

According to this, Smoothie uses a scale of 0-100 and the controller is expecting it.

There is a way to disable the proportional laser power as a command. I would experiment with that setting after I was convinced that there was no opportunity to overdrive the laser tube.

Do you get proportional behavior when you engrave at 5% 10% 15% 20% power? If these are all burn the same strength proportional control be be inactive. If they burn darkest to lightest the laser power supply trigger could be expecting the opposite signal.

G-code Who? I have never messed with the g-code. I get that Lightburn writes g-code to send to the laser to create the designs and commands we setup in Lightburn, but that’s about it. I have never tried manually entering g-code commands. I have been telling myself I need to take a deep dive into the LB software and g-code to fully unlock my printers potential but time, just not something I have tons of.

To answer your question no, if I command 50% power in the LB software I get closer to 75% output from the laser. This is why I suspect somewhere code is scaling the output and I need to reset the scale to match the rest of the system.

I have also never messed with the SD card in controller (shame) so I have no clue what’s on it or how to mod it.

Thanks for the link I will dig into that over the next few weeks as it looks like much of the information I want to get to know.

Any help to how to scale (if the issue) would be greatly appreciated.

Have you considered the Material Test in the Laser Tools window to run a test at low power? :slight_smile: It’s quite handy for disentangling hardware vs. firmware vs. software.

Do you have a current (milliamp or milliampere) meter on the top of the K40?
Is it reading above the level that your tube is rated for? If so, there may be a method to dial-back the maximum current on the power supply. It may be best to preserve tube life while working out what’s happening on your board-swap.

Yes I have a milliamp meter, and I have the manual laser power capped at 42 which keeps my laser under the rated 18mA at 100% commanded power from the software.

I have not done the material test, in fact I just saw them for the first time about a week ago, yes more shame.

No shame, just discovery…
We all start a journey somewhere.

I’ve owned this for over 2 years in fact replaced the tube from wearing it out mixed with overdriving it before I understood, so shame I need to knuckle down and get hip on the firmwear/software/g-code. I also own a 3D printer and need to learn that as well, can we make days 48 hours?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.