Power seems way too high

I have been battling a power issue for quite some time and am at the point that I am about to uninstall Lightburn completely and reinstall it from scratch to see if I screwed something up in the config.

I have a ThunderLaser Nova 51/100. While engraving, it doesn’t seem to care what I set my power settings at, it just burns hot so to compensate, I have to ramp up speed. I have cleaned mirrors/lens, aligned my laser, installed a desiccant dryer after my 2 water filters and still cannot figure out why the power doesn’t seem to respond. It’s always wide open.

I just ran three different tests which are the first 1/2" of a photo prepared using Da Sauce. I ran it at 800/1, 800/20 and 800/100 and the result is exactly the same for all three.

This happens whether I drag an image in and use image settings - manually selecting the image mode and DPI or if I use pass-through after processing the image in Photoshop or Photograv or Corel…

I uninstalled LB and then reinstalled it but it picked up my laser and settings so there must be a config file that doesn’t get deleted. Before I quit for the day and start drinking heavily, I figured I would whine and complain on here in the hopes that maybe someone much smarter than me will say, “well, dips#!+, the problem is…” and we’ll all have a good chuckle at how dumb I was.

ANY help at this point is appreciated.

My feeling is that I edited my config in LB somehow and screwed it up but I am not familiar enough with it to know if I did or not.

1 Like

Does your machine have a power indicator?

Is it just a problem with engraving?

Have you checked your controller pwm signal wire with a multimeter to see if it is actually changing?

If the answer to the above is ‘yes’, I suspect a failing laser psu

1 Like

I am not familiar with the type of controller Thunder uses in their laser machines, so my tip may not be applicable. On Ruida controllers, you can set a minimum laser power (and a maximum laser power). A power setting on a layer outside of either the lower or upper boundary is signaled to the laser PSU at either the floor or ceiling value e.g., if you have the min power set at 50% and a layer set to 15%, the controller will signal the laser PSU to the equivalent of 50%.


1 Like

I was thinking the same as @Bonjour to ask this question as well. Here is a post with some tips on the subject of too much power:

1 Like

There is a power indicator inside one of the compartments. It varies but I did notice that it says Laser Signal: Off. I’m trying to research now to see if that is an issue and how to change it. I suspect that I boogered up my settings in LB somehow and this is the problem.

It’s a Ruida controller. My values were 7 and 70. I don’t recall changing those but it’s very possible. I just changed them to 1 and 99 and will report back.

You will probably not benefit from lowering the floor value of 7. Your 100w laser tube’s lower limit of ignition probably hovers near 8 to 10%.

As for the upper limit, you should calibrate the output of your laser PSU so that the current across your laser tube does not exceed the tube manufacturer’s mA rating at 99%. You’ve been capped at “70%” output thus far (and maybe that was intentional by Thunder).

To clarify, when you set the power level on a layer (e.g., 15% min / 18% max), this level of power is information sent to your controller:


The Ruida controller sends either a PWM output (which the laser PSU translates to 0-5v) or a raw 0 - 5v “analog” signal to your laser PSU representing the specified layer power. Think of 0 volts as the mute button and 5v as Max Volume.

In rough terms, if you had a layer set to 50% power 5v * .5 = 2.5v signal. This essentially supplies your laser tube with half of the potential output capability of your laser PSU which then results in a measured draw of amperage as seen on an ammeter.

But capping the controller at 70% means that the max output value that could be sent to the laser PSU was roughly 5v * .7 = 3.5v.

My point is, you need to possibly trim back the laser PSU so when it does receive a true 99% / 5v value, you are not exceeding the tube current capacity.

1 Like

ThunderLaser has a LB file for performing this test at 10% increments. I ran the test a few weeks ago when the issue first began and the numbers were as they were supposed to be, I’m assuming (10=2mA, 20=07mA, 30=11mA, 40=15mA, 50=19mA, 60=24mA and 70+=27mA) so I started looking for other issues and determined that my air supply was changing temps from my shop to my office (it runs in the wall of a metal building into a climate controlled office) and creating condensation which was affecting my engraves. I installed a desiccant filter in my office and it seemed to fix the problem until the other day when it started again. No matter what I do with the air; no air, little in-office compressor or big shop compressor, it seemed to engrave at 100% (or very high).

I just reran the power scale test and no matter what the power, the output is 15mA, which I know from my previous test is about 40% power, which makes sense since in order to do an engrave and not burn through 1/4" material, I have to crank speed up to 800mm/s.

What’s odd is that when I was just doing an engrave at 800/10, the current was fluctuating from 0-10mA. That’s when I wrote the post a few minutes ago saying that it was fluctuating.

It definitely seems like my PS is not playing nice sometimes. I’m waiting to hear back from TL support but if anyone has any other suggestions, I am all ears.

How is Ruida controller connected to the laser PSU? CN5 is the block having the laser PSU output:

Are you connected using PWM or L-AN1? If your laser PSU is connected via PWM, then the PSU may no be converting the PWM properly. Have you made any adjustments to the frequency settings? You should confirm the frequency is set to 20kHz:

1 Like

It is connected to LPWM1 and the frequency is set to 20kHz.
I just did a Default Parameters reset.
ThunderLaser support page says DO NOT do a factory parameters reset but I’m wondering if I did it a few weeks ago when I was having issues… I do have a tendency to knob-dick and THEN read the manual, so it’s very possible.

You can make a simple test such as the one I just performed. Draw a large shape. Set the speed to crawl and the power to 50%. I shut off my laser PSU (but that isn’t necessary). Run the job and probe the analog output of the controller CN5 Pins 1 & 5 and measure the DC volts to confirm that everything sent from the computer to the controller is correct. You should get right at 2.5v DC:

Then try this same test with 10% power and confirm you get the expected output of approximately .5V:

1 Like

CN5 doesn’t have a connection on pin 5. Pins 1 thru 4 only.

Pin 1 and 5 results in 2.0v at 50% and .7v at 10%

I understand that is how your machine is wired, but the test needs an analog signal unless you would like to make an attempt at measuring PWM.

That’s close enough / within range of an expected result. So this narrows down the issue to either the Ruida controller is not outputting the PWM properly or the laser PSU is not converting / measuring the PWM properly i.e., it isn’t a LightBurn issue.

@Bonjour , do you have any suggestions on how to effectively measure the PWM signal without the use of a scope?

Unfortunately, I can only find my little crappy Harbor Freight MM. If I was still in AIT at Ft. Gordon, I’d have access to all the cool testing equipment, but I’m just a bitter old man now with a laser that wants to scorch everything :slight_smile:

Using an Arduino or a True-RMS multimeter or a meter that offers an average.

I would use an Arduino - if you haven’t got one, a $5 mini will do the job. If you have, you can temporarily repurpose it, even if it’s installed in a project, as long as you can get access to an analog pin.

Any other microcontroller will work, too, but an Arduino is cheap and readily available and there’s tonnes of code around.

The sketch will be simple - connect the Arduino to the PWM and -ve, monitor the analog pin using the Arduino IDE serial monitor in real time as you adjust power.

1 Like

These are great and about $50.



You can connect it to a PC and log, which is a bonus.

Uni-T make some great kit at budget prices. I tend to use it more than the Fluke as I don’t care if I bugger it, where I do care if I’m out ~$600 for the Fluke.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.