Power Settings Won't Adjust

I am starting to have regrets for buying an OMTech laser. I contacted OMT yesterday asking for shipping info of the new power supply. They said they needed a photo of the current power supply, and I responded that I sent them a photo the same day, 7/24/2021. So, 5 days wasted. I’ve forwarded the 7/24/2021 email, with photo, without additions, to OMTech. I also responded to their most recent email and included my shipping info and attached the photo again.

Brand NEW OMTech laser that is not working correctly since before May 7th, UNBELIEVABLE!

Hi all, looks like im having a similar problem to you. just got a 80w co2 laser a few weeks ago. I didnt notice a problem at first because I was mainly doing dither photos. But figured something was amiss when i tried to reduce power to do fine detail on a map and it kept burning spots. tried greyscale output test today and it just burns the whole test as one solid lump regardless of power setting. Haven’t got a multimeter onto it yet but will soon but i suspect its similar to yours. Am super keen to learn if the psu is the issue. Btw 8.01.67 firmware version

Fyi just checked my wiring… time to get the multimeter out tomorrow but my psu is connected to the analogue output of the controller not the pwm.

That is odd, what type of power supply? I think they will take an analog input, but mine is wired up to the LPWM1.

Assume it goes to ‘IN’ on the laser power supply?

Yes in on the “IN” in the psu. Its a laserpwr.com supply hy-x80. I tried changing just today from the analogue signal to the pwm and same result. I measured the voltages from the controller and they are responding to changes in power from the pc out of the controller so im guessing its a psu issue.

Check out this post, and down at the end the post by wasteofspace with some details from Russ Sadler that might have something helpful in diagnosis.

The post is Laser Power Fault.

Good luck :slight_smile:

Hi mark, today I received the power supply, I changed it and the machine seems to be working properly, the problem was the power supply, not the firmwear. Hope you will manage to fix yours too. I bought mine from a trust worthy Chinese company called Rayther Technology who have the best customer service, I was served by Miao who helped me a lot

Hi Carmel, that is awesome! I am so happy that your machine is working, and anyone that has a similiar issue will have some confidence that it might be the power supply. I’ve seen a few posts on LB and they never before posted the fix, so this will be a great asset for Light Burn users. Thanks again for posting your fix, and to the several people that offered there help to us on here! I’m hoping to get my power supply soon, they emailed that most get the replacement 4-10 days, it’s been more that 4 days since they emailed they sent my photos. I think I’ll email to see if they can provide a tracking number. I will post the results when mine arrives. Thanks again!

Glad you’re up again. These things can be frustrating. Thanks for advising on the fix. Many came here and on the fix, they never tell anyone.

How many posts have you gone through looking for a solution and the fix is never posted. :smiley_cat:
Take care; have a great time with your working machine :slight_smile:

That’s great news! I’m very surprised that the power supply was the problem but I’m sure glad that fixed it for you.


This is my old PS that never worked good

Bingo… i have had some luck too. I took off the power supply. I could find the screw for adjusting power but also found a switch. After some googling i found out this switch basically bypassed the power adjusting potentiometer and was clearly set to the wrong position from factory… i switched it over and now get perfect laser power control from lightburn



You have eagle eyes. I couldn’t hardly see it. :slight_smile:

Yes it is very very small but mine was on the with pisition

@jkwilborn the only way of discovering it was to remove the psu from the panel. The thing is with the switching running the way it was i presume it was running full power in the co2 tube… not ideal conditions for my tube. Luckily only have machine about 3 weeks so limited time

It’s working, don’t sweat the small stuff you have no control over :slight_smile:

OMTech emailed again today, might get power supply in 3-7 days.

1 Like

FIXED!!!

So, it was the power supply. It is working correctly now! A big thank you to everyone that replied to our posts during this process!

Worth noting:
One trouble shooting process which made the tech folks know it was the power supply was all the info I sent to them, but the last test they had me do was remove the high voltage plug on the PSU and push the laser button and the mA meter read 13mA.

I received the new one from OMTech yesterday, plugged it into the machine today without the high voltage plug and pushed the laser button again on the PSU and it read 12mA, SO I don’t know, but it is working correctly for the first time…not running at 100% power and max mA.

I could not see the micro switch on the power supply when installed, but was amazed it was there when I removed the bad PSU from the machine and saw it.

Old bad PSU…switch switched to the left
New PSU…switch switched to the left
Cloudray PSU…switched to the left

SO, I’d say the switch should be to the left?

Thanks again everyone, I hope this helps some others from the long drawn out process of wondering why their machine won’t adjust power and burns through 1/8" plywood regardless of the setting!

Mark C.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.