Problem LightBurn and TowTrees TTS-55

I have a little problem with my laser: when I turn on my laser under LightBurn 1.2.01 it tells me: your grbl may not support variable power mode m4, if your laser does not turn off between cuts, switch to the grbl- m3 device, but I don’t know which setting to change in GRBL 1.1, I vaguely saw on the forums, they talk about $100 and $101 , mine are set to 80,
With Laser-Grbl everything works but with Lightburn impossible to make the shade of gray “m4”
could you help me?
Best regards
Materials = TTS-55 + extension 600x600 + rotary

Run $I in console. If the version listed is >= 1.1f then you can use GRBL, rather than GRBL-M3 device profile. Sounds like you’re currently configured for GRBL which is preferable if you can use it.

Once you’ve confirmed you are eliglble to use GRBL then confirm these settings.

  1. $30 is equal to S Value Max in Edit->Device Settings. If they are not equal then change S Value Max to match $30
  2. $31 is set to 0; if not, change
  3. $32 is set to 1; if not, change

If GRBL version is <= 1.1e then switch to GRBL-M3 or see if you can upgrade your firmware.

Hi, thank you, but I can’t see the GRBL version, it just boots and writes GRBL 1.1 " no letter " [$ for help] on Laser Grbl and Also on Lightburn

thank you

Can you run these commands in Console and then copy/paste the results here?


Also, a screenshot of Device Settings please.


Perhaps you’re not following me.

Can you go to the Console window in LightBurn? In the field that I’ve highlighted yellow in the screenshot below I’d like you to enter these 3 commands, one at a time. So copy or type the command and then press enter.



Once you’ve run the commands, select the outputted text from the Console window, then copy and paste that text here please.

You could also do this in LaserGRBL where it says “Type gcode here” in your screenshot.

Also, can you go to Edit->Device Settings menu and then take a screenshot of that window please?

[MSGUsing machineLKS TTS]


I think I understood, when I turn on the software before the hardware, = message “your grbl may not support variable power mode m4, if your laser does not turn off between cuts, switch to the grbl-m3 device” but if I start the hardware before the software = everything is ok MESSAGE CONECTION AND OK
thank you very mutch

Then perhaps I misunderstood.

The settings themselves look okay.

Can you also take a screenshot of Edit->Device Settings?

I think what’s happening is that since the version number doesn’t include the letter variance LightBurn is not sure if the laser can support variable power.

In practice, are you having issues getting variable power with M4?

When i star the machine before software the variable power fonctionne :wink: but if i star the software before the machine, the power il full, thank you very mutch :slight_smile: have a good day

That’s odd. Not sure how that would work. But sounds like you have a workaround at least.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.