Problem since last update

Hello! I am using LightBurn 0.9.18. Since i’ve updated to this new version i have an annoying problem: When i open a file (a .lbrn file) the design is flipped upside down (mirrored). Why and how can I correct that? Thanks ezgif.com-gif-maker

Did you change your ‘Device Origin’ to a different corner? It’s currently set to upper-left, but if it was front-left when those files were created, that would do it.

already thought to that, but the answer is no

and if it was that, why it does not affect the TEXT ?

Text is always generated upright - it’s just how it works. Are you sure that moving the device origin to front-left and re-opening the file doesn’t fix it?

https://www.youtube.com/watch?v=Bu-SNujOgsw check…

You’re only changing the JOB origin, not the device origin. Device Origin is in Edit/Device Settings. It needs to be set to the corner that your laser seeks to upon startup:

image

1 Like

tried that though…same problem

The origin that was in the file when it was saved is key. If it was saved with the origin in the incorrect corner, then you correct it, it will load backwards. You’d need to flip the design in your files that were saved with an incorrect origin, then re-save them with the correct origin.

1 Like

it does not fix it, but it does not matter, this wont be a problem compared to what lbrn can do, is the best software i ever used in the last 3 years. Cheers

Were these files created with a different device profile? The Origin corner in the Device Settings window is what controls mirroring. If your files are upside down when you open them, move the Origin corner from back to front (not the Job Origin), then re-load the file.

Yes, they were made with a different device profile. I have tried to set the origin corner in the device settings window, i have tried each one of them and tried to reload the design, even other designs, but that didnt solved the problem. I am just wondering why this problem came up with the new update? never had it before :smiley:

Which version were you running before? (IE, what’s the last version you used where these worked as you expected?)

Solved just now: Resseting the ruida controller and set a new origin on the controller, delete the device from lbrn and added the same device as a new one. Now it is working with same old settings (on lightburn, same origin corner). Thanks for the answers

0.9.14 or 0.9.16 can’t remember exactly srry

We’ve been having the same issue. I try not to reset that computer, since it really is only for the laser. But when it does, now I have to go in and reset origin to the top left and to absolute position.