Problem with rotary attachment

Greetings.

I’ve got a small problem with my rotary attachment (again). This time, all the connectors are plugged in properly, unfortunately.

I don’t have a computer linked directly to the machine, and instead upload the files I want it to work on by USB - as a RD file. The problem I’m having is, no matter how many times I try to input the settings in the Rotary setup tab, they don’t save. As a result, the attachment spins more than it should, making it impossible to engrave what I wish.

Any help would be greatly appreciated, cheers.

Rotary settings are saved on the controller itself. It is not possible to use the rotary unless you are connected to the machine with a computer, at least long enough to turn it on and set the diameter value.

They’re sticky too, which means when you’re done with rotary mode you have to turn it back off, and write that setting to the controller.

Thanks Oz. That explains a lot actually. Much appreciated!

If I may ask, before I give up on this for the time being, I’ve already done some engraving on glass with rotary, on a wine bottle. It worked that time, seemingly without problems. This time, the rotary turns almost twice too much

Do you think that was just a chance success? Sorry if I’m being a bother.

It would have had to be, yes. Depending on the size of the job and the rotary you have, it’s possible that the numbers just worked out. There is no rotary information saved in the files sent to the laser or saved to USB, but it’s possible that the sizes aligned in such a way that the steps sent to the motor were roughly what they needed to be for that job.