Problems deselecting items that have been importing

running LightBurn 1.4.03 on MacBook Pro running MacOS Sonoma 14.1.1

OK here is my problem. Have a file open and when i import another file into it i keep getting the same problem, not being able to deselect the items i have imported. It doesnt happen every time but enough to be annoying i would say probably 30-40% of the time. Any ideas i have restarted, reopened files, shut down everthing restarted laptop problem keeps arising SOMEBODY HELP

Push ESC on your keyboard to deselect.

Bloody typical well done tried every other avenue apart from the simplest.

Yes you can press escape but this is not how it usually works, you used to just be able to click anywhere on screen to deselect. Why has this stopped working? When you press escape this sometimes has different affects on what you are importing. Sometimes it ungroups parts which is not ideal.

If multiple shapes are selected, clicking on one of them leaves all of them selected. If they’re grouped, the same sort of thing happens.

The trick, such as it is, is clicking on a blank area within the selection that’s far enough away from the shapes to not fall within the object snapping distance.

All of that can be difficult with a crowded selection, but it still works.

Either of these methods should work and should in fact be equivalent.

@ednisley has called out techniques to do that with clicking out of the selection.

This part is not making sense to me. By default imports will be grouped. Nothing you do from a selection perspective will change that grouping either through click or ESC.

Do you have a specific example .lbrn file that you can upload that demonstrates this happening? I will try to reproduce the issue.

No unfortunatly that dont work i have zoomed right out and clicked on a blank area. This has only started happening i think from the last MacOS update

I’m wondering if you possibly have a stuck CMD or SHIFT key. Or if there’s possibly something in the OS that’s simulating those conditions.

Try unplugging the keyboard and testing this.

this is not a specific file it is all files i import a file all objects are selected, you used to be able to click anywhere and everything would be deselected. Now as i say 30-40% of the time this does not happen. I press escape they deselect, then if i select an object if i select another object it is like i am holding shift down and selecting another object.

its a MacBook

Seems if i hit shift then i can deselect, but it doesnt matter which shift i hit can be either so its not a stuck button.

Sounds like it is somehow shift related. Normally holding shift would not allow you to deselect.

Can you try entering text in LightBurn. Does it force capital letters?

Also, if you enable the on-screen keyboard it possible that it may reveal keys thought to be pressed but not certain.

Do you possibly have an older butterfly keyboard? Those were notorious for stuck keys.

The thing is it doesnt force me to type capital letters, so cant be shift. What else could it be?

Nothing stuck on the onscreen keyboard

Ok it seems to only happen if i import using the shortcut keys of Command+i, if i import from the drop down menu under file import everything is fine.

Do you have Select imported shapes turned on? If so, turn it off

Just tried that Ralph, that seems it would cause a whole lot more problems as when you import nothing is selected. So when you import 1 file on top of another file this causes 2 files to be mixed up

If this is only occurring with CMD+I, I’m wondering if the key that’s stuck is CMD.

I’ll attempt this on a Mac tomorrow when I get a chance.

It happens on an external keyboard also

Okay. So just to make sure I understand the steps for when I try to reproduce this:

  1. Push CMD+I, import file
  2. File will import selected
  3. Try to click outside the design to deselect

And you’re saying this happens 30-40% of the time so sounds like I may need to try this several time.

Am I missing anything?