Problems with traversal moves

Hey guys, have some problems with traversal moves. Cant fix that by myself so maybe you can.
When i choose in layer to cut in line tvarersal moves go well like have to (first z moves up and when do a move), but when i choose offset fill (my way i have to fill race circle) it filling okay but when need to cross circle he dont move up z and just moves across circle, and that way doing lines who i dont need. Wheres the problem?
Picking up images, who maybe gonna help to realize what the problem

1 Like

Grabbed a few previous posts that should help.

Welcome! We have seen this a time or two. Take a look at this post for resolution.

And this is worth review for your setup:

Thanks for trying to help, but no one of that helped

OK, so what did you try, exactly, and what result are you observing? You have not provided much technically to help us help you.

Firstable i tried to write in console $32=1, but i had an error who is saying invalid statement, and that is because i have numbers only to $27 i will pick a photo below and you will see, next thing what tried to do write numbers the same like you sens me for my machine setup, and that didnt helped to

I had to note again then i engraving only line traversal moves ups z fine, only on offset fill dont move up.

You are using an old version of firmware. If it is not the latest version of Grbl (1.1f or later) then you should use the device in LightBurn called “GRBL-M3”.

This sounds like what a number of users experience when using older versions of GRBL (older meaning not the latest 1.1f) with the “GRBL” device in LightBurn. If this is the case, try using the “GRBL-M3” device in LightBurn. We have seen numerous users with diode laser machines that run an older version of GRBL and the laser does not turn off on travel moves. This is why the “GRBL-M3” device was added.

Where can i find that device? (GRBL-M3)

Look to the ‘Laser’ window in the lower-left of that window (marked with #1).

And this is worth review: Common Grbl Setups - LightBurn Software Documentation

Just now i tried an older version, that one who you told me to use, and z moves are the same, nothing changed, problem still are, what i should i try next? Thanks for helping Rick

Did you enable support for Z moves on the ‘Device Settings’ page? Device Settings - LightBurn Software Documentation

Yes sir, ofcourse. And checked again on the line mode z moves perfectly except on ofsset fill, maybe i should do a video, and you will see exactly how it going?

Please. That might help us better understand what you have and what is not working as you’d expect. :slight_smile:

Thanks Janos, please post both the saved GCode and the LBRN2 file of this “racetrack” job for review. :slight_smile:

Any ideas @Rick ?

It looks like you’re trying to use LightBurn to drive a CNC rotary spindle, not a laser. It is not designed for this, and will not do all the Z-retraction moves necessary, because it is only meant to drive lasers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.