Problems with UI grid legend

I have a problem which is more an annoyance than anything else but wonder if there is a solution.
Here I have the visual grid set to the default of 10 and the work area zoomed so the grid legend is clear to read.
However if I were to change the zoom, e.g. to zoom into an object or, as in this case, simply click the ‘zoom to frame’ selection then the legend becomes unreadable.
It’s the same with other grid settings - I can find a sweet spot but zooming will change the legend and it will start overlapping again.
I don’t actually use the measurements so ideally I need to switch them off, I just use the grid for alignment.
I have also played around with icon and font size, plus the Windows DPI settings but can’t find a solution.
For reference i am using Win11 on a 3840 x 2160 screen.
All suggestions welcome.


I’ve always had this problem on my 55" monitor but like you I just ignore it. Don’t recall my resolution specs at the moment but IIRC, it’s close to the same as yours.

Fairly certain it’s a screen resolution issue.

1 Like

There are a few cases of ‘large monitor’ or ‘small monitor’ driven behaviors. I have asked internally about this behavior and will be looking for feedback.

In the mean time, please reduce the font scale for the Windows 11 desktop. It affects the whole UI.

Change the size of text in Windows - Microsoft Support

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.