RA2 Pro rotary attachment mirroring output

This generally happens when the ‘origin’ of the machine/software is changed.

Check ‘edit → device settings’ and ensure the origin is proper for your machine.


Origin is set to upper left which I believe is right. I never changed it.

Was the failing artwork used on another machine that had a different origin?

There are limited places this happens. If it’s not an origin issue, I don’t know what to say…

Good luck


It was created in Lightburn using text and an imported bitmap.

I was helping a new user set up her RA2 today in a Zoom session.
Although we had the rotary settings for chuck set to mirror, it was inconsistent. Sometimes switching layers would get it to be ok. The odd things is that if it came out mirrored, and then I mirrored the object to compensate, it still came out mirrored. Then when I put it back the way it was intended, it worked fine where it had failed one or two tests earlier. The job used current position, with the job origin left middle, chuck is on the left.
The job was text and shapes created in Lightburn. Behavior was the same for both line and fill tests.

Any thoughts about the inconsistent behavior are appreciated.
The Lightburn software and D1 firmware were both up to date.

Apparently there is a problem with the latest D1 firmware… it messes up mirroring.
The easiest workaround is to put the chuck on the left side instead of the right side and turn off mirroring.

Hopefully they will get this resolved.

When using the Rollers you put the motor on the right hand side where you can read the numbers.

When using the Chuck you put it on the left as if it were a Lathe.

This is kinda standard.

Totally depends on how the motor is wired which direction it will turn. I ran mine on the left until I corrected the wiring…


Reversing the orientation of the rotary is a workaround. The mirror option used to work properly, but recently started acting erratically.

I have 4 lathes, so I am fine with a left side chuck, but would prefer to have one orientation for both uses and have the Lightburn mirror setting apply as intended.

If it isn’t predictable, then the way the rotary is set in the machine is irrelevant, as you pointed in post 6.

Where it “worked then didn’t” it would have “didn’t then worked”. It only is relative to how to fields are energized.

There is no logic to reversing the hardware if the software flips it… randomly… I wouldn’t consider it a fix by any means, sounds like either way it’s a crap shoot.


Jack, it behaves normally when Mirror is turned off in Rotary settings. When turned on, it becomes weird, for example, using current position the green job origin dot appears way outside of the job area… very strange.

Why do you use ‘current position’ with the rotary ?

I have always used ‘user origin’, don’t have to set it back when it hits the limit.

Did you try it with user origin? I assume you can set a user origin?

This would seem to be a software issue as you mentioned earlier with Xtools firmware. So until that’s updated, there’s isn’t much you can do… if that’s the case.

Again, it wouldn’t matter which end the motor is on… the software is doing it… :frowning:

If indeed it’s the firmware…

What does seem questionable is that Lightburn is showing the green origin block elsewhere. If this problem exists in the machines firmware, this should not occur.

This is problematic because you configure Lightburn separately from the machine. Such as machine/software origin. You get unpredictable results when they are configured incorrectly.


The green dot positioning certainly is puzzling.

I did not know the mirror option used to work mine never did. Thank you for letting me know.

I made a quick video that shows the moving green dot.

Job is set to Start from current position, with job origin at top left.

Note how the green job origin dot moves off of the object when rotary mirror is selected.

Is this the expected behavior??? If so, why?

Disregard the selected Y axis choice in the rotary setting in the video, it should be set to Z on the D1. The results are the same.


My Ruida doesn’t do that, that I can remember…


When I made that video today, I had Lightburn connected to a different device, so it’s not limited to the Xtool D1 device configuration (though this config is likely very similar)

A home have thoughts on the green dot position?

I happened upon this thread looking for a similar symptom in another thread.
This looks like this documented concern.

Yeah. That was my thread, also.