RDC6432g will not home

I have been if the process of rebuilding my laser and have switched control from LinuxCNC to a RDC6432G, but the transition has been far from smooth. it took alot of work just to be able to communicate with the laser because i am using a macbook and macs are very finicky with serial usb especially with CH340 type chips.

From what i understand, as soon as you power on the machine, it should seek home. this controller doesnt and nothing i do seems to change that. i have prowled over forums and google for the last two weeks trying everything including two factory resets. i have tried every combination of every setting there is, but to no avail.

here is the rundown of what i have and what is going on –

  1. when the machine is powered on, it briefly displays “resetting system” for about half a sec or so and then that is it. x y and u all show 10000 for position. machine jogs in all three axes with no problem
  2. when i do a axis reset, it goes through a homing sequence just fine, and then x y read 0 and u(z) reads 10000, but as soon as it is powered off, then see point 1
  3. when i home in software (ive used both lightburn and rdworks), it totally ignores the homing switches and crashes into hard limits
  4. in the diagnostics pane, all switches register as they should, (NO lever switches) off when open and on when triggered
  5. if i have it set to use a limit switch and home switch, when jogging all is normal, but when switch is triggered only one direction can be jogged (found this out hard way coming from cnc world where most limit switches are NC)

so far it seems that nothing i do can alter these and if i cant get the machine to home, i am just sitting on an expensive and time consuming paperweight.

i know this is a seriously stupid question, but i have to double check, when you do a factory reset it only resets the vender settings, not the actual firmware right? you never know. im pretty sure not because it is still branded cloudray after the reset, but i wanted just to make sure that it was just the settings that are reset and not the entire firmware reloaded.

are there other settings that you cant normally access through lightburn that get changed during a reset and if so, how do you access them?

anyway, thanks for reading this and i hope somebody has some input that will help me!

I always think configuration when strange stuff happens. How much of your applicable data have entered into the Ruida? I mean home seek direction acceleration and so forth?

This isn’t mine, but another Ruida for a Chinese laser. Maybe that will help you set it up.

Home is home, it shouldn’t have different results for the same operation.

Good luck

Hey, that looks like the configuration for my machine. :slight_smile:

Do you have homing enabled for each axis?

i have started from a fresh reset 3 times now and i also have a backup of my configs. I have tried every combination of homing and limit switches that you can have and nothing seems to actually make the machine home itself. i was under the impression that it should do this on its own immediately on power up.

Can you post your config so we can have a look?

so here is my configuration file that im currently using. the actual numbers for step etc are just ballparks to keep me within my bounds and not lose steps while im trying to get the homing issues ironed out before i can get to calibration.

i was using rdworks when i made this backup because i had read somewhere that it was possible to access more settings with it than lightburn, but i did not find that to be the case. in fact lightburn is alot easier to edit the settings aside from the names of some of the parameters being kinda wonky
Default.RDVSet.txt (2.4 KB)

thank you for all the replies!

i was beginning to suspect that i have a defective controller, but it turns out that i have a solution!!! now everything works correctly, so i will post this to help anybody else in my shoes. after emailing cloudray, i received a detailed fix for this problem. i do not know if it is specific to only 6432 controllers or possibly more, but here it is.

first off, far as i know this can OLNY be done using RDWorks 8.01.54-20210513 (hint hint - this might be a useful function in lightburn). the only place i have found this version is on cloudray’s site.


there is a hidden menu on it with a SECOND set of vendor settings.

so once you have a connection, you read from the controller as you would normally change your settings and write back to the controller and VOILA! it now homes automatically on startup and reset.

also, i have seen a few posts of people asking for just the opposite, they do not want their machine to auto home on startup. why? who knows, but possibly this might answer their questions too…

again, thanks to all who helped me and taking time to answer my questions! now only to figure out how to use my U axis as a Z, but i will ask that in a different post

Hope you don’t mind I stole your config post :slight_smile:

No, that’s cool. I posted it in case it might be useful to someone.

Yep, always seems to be configuration. Thanks, did you know about the ‘sub’ menu in RDWorks?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.