RDC6442S-B (EC) Lightburn

The laptop with Win 10 is connected to the laser via USB. The USB port is on COM7. However, Lightburn does not recognize the RDC6442S-B (EC). When I set the GRBL manually, Lightburn gives a “Ready” but the laser does not respond. What settings do I use to get the laser to work? Thanks for all the help.

How did you try to have LightBurn recognize this laser? If you click my profile, you should see that I have this same controller in one of my production machines. It works great.

This will not work as you have a Ruida, not a Grbl device.

This is the process that should help you to get set properly. Read here and then let us know exactly where along this path you are having difficulties completing. https://lightburnsoftware.github.io/NewDocs/FirstTimeSetup.html

I hit “Devices” and then “Find my Laser”. Unsuccessful.

In the case of manual entry, “Ruida” is missing from the list.

If you are not seeing the Ruida controller in the list, this would indicate you do not have the correct license. You need to have the DSP version to support Ruida.

We offer an upgrade path here: https://lightburnsoftware.com/collections/frontpage/products/upgrade-gcode-to-dsp-license

You enter your current key, pay the difference and away you go.

Thank you for the information. Ordered an upgrade right away and try it out tomorrow. It wasn’t clear to me that I lack the appropriate license. Report to you when it worked. Thanks for the support.

1 Like

Thank you for support! It work well with the License.

You might also need to install the FTDI driver at the end of the installation. When you did the ‘Find my Laser’, even with a GCode key it should recognize it, and tell you that you have the wrong license type. It wouldn’t get that far if the driver was missing.

https://lightburnsoftware.github.io/NewDocs/Installation.html#windows-installation

Thanks for the answer! After the license was extended, Lightburn didn’t find my laser automatically either, but the manual integration worked great. Now the laser is running as it should. Is there a link to the FTDI driver so that I have the current one. thanks

Just re-run the LightBurn installer and check the box at the end.

Thanks for the tip, have a nice weekend. Hans

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.