RDC6445G crashes on fill

Hello, whenever I send large fills made from vectors, or images (and by large I mean more than a few cm square), my RDC6445G hangs. Sending the job and starting from the machine, or starting from lightburn changes nothing. If I press play, it will do 1 vector then stop, and the vectors are also clearly not in the right place.

A couple of things to check:

  1. Are you speed settings unusually high? What happens if you dramatically slow your speeds?
  2. Is your controller storage potentially very full? Try removing all files from the controller and retesting.

Hey! I actually just fixed it after a few months of trying to figure it out (but minutes after posting lol). But thanks :slight_smile: Turns out that for large scanning areas, path optimization just breaks the ruida file (including from RDworks). I just had to disable it.

Also, speed was just 200mm and I keep the machine pretty empty of jobs (like only 1-2).

What specifically? I’ve never seen anything like this so there may be something else going on.

Actually I spoke too soon. It works from RDworks when I remove optimization, but still doesn’t work in lightburn. It just makes the controller go to pause after every vector segment, and the vectors are often not located at the right spot either. This happens when I do different types of fill, but to keep it simple, right now I’m trying to fill a rectangle, nothign more.

simplified file that breaks my RDC6445G.lbrn2 (2.9 KB)
file that breaks my RDC6445G.lbrn2 (18.7 KB)
Akarios card holder.dxf (175.8 KB)

Sounds to me like the stepper motors are losing steps. Has any of the hardware been changed or any machine settings changed recently?

If you dramatically slow your speeds does the behavior change?

I’m not talking about slightly off, I am talking about being 10-20cm off, but if I stop and run a file without a large fill, or with small fills, there is absolutely no issue. Also, the file sent from RDworks without optimizations is also working well (except that my 0 seems off in that program)

You’re likely losing steps during initial acceleration for the scanning operation. Again, has anything changed on the machine or settings?

In either case, can you try dramatically reducing speed on the fill and seeing the results? That will potentially narrow if it’s exclusively acceleration or speed setting that’s contributing.

nothing changes between doing a small or a large scan area. I can literally just open a blank lightburn file and make a rectangle with the toolbar and if I make it big enough, the RDC6445G stops being able to run the file. Exact same parameters in RDworks (200mm speed), works just fine as long as path optimization is disabled.

So it’s neither speed or acceleration since smaller rectangles work without issue, and the laser works fine up to 300mm+

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.