RDC6445G Rotary

I’m trying to setup chuck rotary on CO2 laser. RDC6445 controller firm ware main board 15.01.22, Lightburn version 1.2.01. I set up in rotary setup. Chuck is enabled, Rotary enabled. Test will move x axis not y axis. I can move manually settings don’t change rotary. Using switch to change from Y to Rotary. Thanks

Many do this, but it’s the first place to check for proper operation.

Assuming it has never worked, what guide or setup did you follow?

Can you bypass the ‘switch’ and ensure it’s still failing with a direct connect to the Y axes?


I followed the setup in your document’ for rotary. The Y axis doesn’t fail it is not getting signal from controller for the rotary. The Y axis works fine with the switch in the Y axis it will work for rotary in manual mode for rotary, but when setup is enabled for rotary it sends signals to X axis when test for setting steps and size. If I run program, it moves the rotary not Y axis. I can’t change settings in setup that makes any difference for rotary. It’s using the settings for Y axis for rotary. Switch is hard wired for Y and Rotary. Thanks

Not following you here.

The Y axes works and when you switch it to the rotary it will work manually, but fails when you select rotary from the laser tools drop down?


Yes, the test button runs X axis not rotary.

I can’t say I’ve heard of this… There is no option on my Ruida to enable the X for a rotary, so I don’t know what to suggest.

If you don’t hear from someone about something to do, I’d drop support a note and ask them. Make sure you note the version of Lightburn you’re running and insure you’re running the latest and greatest.

Good luck


Lightburn version 1.2.01 There is no X to enable in setup which is only a software problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.