Red & Blk laser = X Axis way off

Laser 500x700 Red and Black Orion 80 watt has been working fine, I’ve been using LB and engraving cups all day with the rotary.

When I’m done, I power down, unplug the rotary, power up restart LB, and make sure it’s set not to use the rotary. X axis works fine, and travels a real 700mm, but x is only moving 1/2" the distance it should but repeats perfect, so I doubt it’s slipping.

I reload the vendor settings (I saved when I got the machine) and no difference. I triple checked rotary is off, in RD works and in LB. What else would cause this?

No switch settings were changed on the driver, and no steps or anything were changed.


Did you reset back to your absolute origin after you unhooked the rotary at the control panel on your machine? I have had this happen when I set my origin to User when doing rotary work and forget to change it back to 0,0.


No, I didn’t do that, and I hadn’t done that before but I went into RDworks, and USER, I did a read, it said Rotating device was Off. I enabled it, wrote the settings, then read them back, it showed ON, I turned it off, then wrote again, and now it works. I’m not sure what happened but it’s fixed now. Weird, I never use RDworks so I’m sure something in Lightburn or something I did didn’t allow it to set back properly.

Glad it works.

When you say, “run LightBurn and make sure it’s not set to use the rotary” - Are you checking this setting on the main Laser window display, or in Tools > Rotary Setup? The first only updates when the controller connects. You have to power the controller first, then run LightBurn, or, with LightBurn running, right-click the Devices button to reset the connection, and the main panel switch is updated then. The Tools > Rotary Setup screen is updated when you enter that screen, so the status there is always accurate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.