Relative Z Not Working as Expected

I searched and read for many hours and think I’ve seen all that is available on this subject. Throughout, I believe I have tried everything suggested and then all that I could think of, but I can’t seem to get the Z to stay put when I start to cut.

I have enabled Enable Z and Relative Z in settings. Material is set to Zero. I can jog Z just fine. I have set Number of Passes and Z Step Per Pass set, but no Z Offset. Start From is User Origin. Also tried Current Position. (Not interested in Absolute in this job’s case.)

After I focus, roughly 1.5" above my material, I set my Origin and Finish Position there. Get Position reads X, Y, and Z correctly. Go to Origin works fine, keeping Z where I put it.

When I hit start, Z goes to Zero (so now, out of focus), X and Y complete Pass 1’s motions, then Z drops the specified amount, etc., just as expected.

I’ve shut down everything and rebooted. Checked my settings multiple times. Deleted and recreated the design file within LB.

So, have you any idea why Z zeros out at the beginning of the run, vs. staying where I put it? I believe I’ve read that staying put and then moving relative to that position is what defines Relative Z.


LightBurn 0.9.02, Shapeoko 3 XXL and Their v2.4e Controller w/GRBL 1.1f, JTech 3.8W, Win 10

There was a bug in relative Z handling when using it with any of the relative coordinate systems (User Origin or Current Position). This is fixed in the upcoming release.

Thanks, Oz. Have you an ETA on the release?

Hoping within a week, but it will depend on how testing goes. If we find anything unstable it’ll be held.

I understand. Thanks. Appreciate you guys.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.