Replaced controller (Ruida)

Try to be gentle:) don’t know too much about lasers or computers, just a woodworker who wants to use a laser.
Had a ruida controller go bad and had to replace it.(expect no help from any of these companies who say they work on any laser) first, I assume I have to reset the controller to default, I’ve seen a you tube video on that. My lists are all in chinese but I can count down to find the default setting. Is ther anyway to change this to english? Is this all I have to do? This laser came with RD works but I switched to Lightburn shortly after I got it.
Thank you

Do you still have the old controller?

That generally makes things much worse.

Find the controller manual (search online for the model number) and puzzle out how to switch language; it’s probably in the list of options opened by the Menu button on the controller display.

Then, do this:

  • Start LightBurn and connect to the laser
  • Go to Edit → Machine Settings
  • Click Load from backup
  • Pick the most recent backup file
  • You should be back in operation

If that sequence doesn’t work, then having the old controller in hand will be very helpful.

Ed,Thank you very much for your help. Got it in English and went to the lightburn edit to machine settings and its telling me it cant read the controller. I also tried to see what part of the old one wasnt working so I replaced the controller and it worked as well as the new one, Then I added the display, the not connecting to the controller was gone. It worked just as well as the new one. However, the water pump works and the fan works, nothing else. I had a file on the old one and I tried to get it to frame or run. I got a message saying ‘water error, system paused’ don’t know what that means
Any help would be appreciated.

Yeah, none of us work well without our heads …

You won’t be running the laser with the old controller, so don’t worry about any of the old cut files stored on it and ignore all its kvetching about water errors and suchlike. You need not connect any of the stepper motor wires, just the power and USB or network cable.

Do whatever you did to connect to the controller back when you set it up with USB or network.

When it’s connected to LightBurn:

  • Go to Edit → Machine Settings
  • Click the Read button to read the controller settings
  • Click the Save to file button and give it a memorable name

Then close LightBurn, swap in the new controller, wire it up to the laser and your PC, start it up, and start LightBurn.

When the laser is connected:

  • Go to Edit → Machine Settings
  • Click the Load from file button & use that memorable name
  • Click the Write button to send the settings to the controller

At that point, the new controller should behave just like the old one and away you go.

Thanks Ed Will give it a try


I’m thinking he swapped it out with the original… it’s not really too tough, it’s all connectors… but it’s not clear exactly what he means by that or that it’s working like the new one.

@Bob1 water error is when the signal from the coolant flow being active is failing. Do you have a chiller running? This is the WP1 input, assuming 1 tube.

These are inputs to the Ruida… you can see them in Z/U → Diagnosis screen on the machine console. Some controllers also have indicator leds showing the state of the input.



We’re trying to transfer the configuration from the old controller to the new one, under the reasonable (to me, anyhow) assumption whatever values are in the new one will be suboptimal.

That should be possible either from a previous backup or the old controller; extracting them from the controller ensures we get the most recent values.

The problem I have is when he states

There should be a difference…


I had removed the original unit about a day before the new one arrived. Put the new unit in place and the cannot connect to controller disappeared. Tried doing what Ed said but the loading and uploading in the edit command of Lightburn was greyed out. The water pump is running, the exhaust fan is going and the diaplay unit I can use the keys and such. I did get to change it to english. I attenpted to try to discover what part of the old controller was not working so I plugged the old display into the new controller and the message about connecting to the controller was gone, could aslo use the display keys for the display. Tried the new display with the old controller. Worked, no message about connecting to the controller, same thing, water pump, fan, nothing else. Put back the original display and the original controll and the message is gone about connecting to the controller, can use the display keys for the display unit. Went back to see how I originally installed Lightburn and apparently I had a little trouble originally did it. RD works was already installed and Oz suggested I use the I believe was the FTDI driver and apparently it worked after that. I’m trying to find that again to give that a try.

Thanks for all the help

If you have a lan … do yourself a favor and use an Ethernet connection to your lan from the Ruida…

No drivers to mess with and better consistency…