Reset to continue

What is happening here? I’ve had it working a few months ago come back and this is happening.

Notice the “ALARM: 2” in the console output. this is a “Soft limit alarm” produced from grbl. The description of this alarm is: https://github.com/gnea/grbl/blob/master/doc/csv/alarm_codes_en_US.csv

G-code motion target exceeds machine travel. Machine position retained. Alarm may be safely unlocked.

Also looks like your machine is reporting it is in negative space, which would produce this alarm. Do you use macros to flip between spindle and laser? Did you possibly reset for use with your router and not run the macro to reset your system to run in laser mode again?

Hi Rick the image is sitting in the middle of my bed I’ve got something screwed up somewhere

-27 & -20 LOL yes I’ve got it screwed I don’t understand what to change it where to change it.

image

Please update this when you get a chance. :slight_smile:

Looks like you are using a JTech laser mounted, but do not see the control system you are using. Others have benefited from this setup walkthrough provided on the JTech site. https://jtechphotonics.com/?p=10204 And, Try setting $10=0 - I think the JTech article is still missing this.

Additionally, this is a good refresher - this addresses the negative coordinates used by XCarve and other common CNC systems, and how to use an offset to fix it: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

1 Like

Update what? BOBS E3? Also where to put $10 setting?

Update your profile, please. Have a look at this for details. It helps us provide better, faster support. Please Help Us Keep the Forums Organized and Support Efficient

You enter firmware commands in the console as described in the JTech doc I linked above. Did that not work for you?

Duh I’m an idiot LOL there was another image way out in left field

Thank you Rick for taking the time to deal with me

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.