Resetting x and y axis for my workspace

I’m trying to find help with resetting my workspace parameters for the x and y axis. More so the x axis. It seems as though the laser head is trying to move off of the table to the left side when I manually move the head, and as a result the laser head is banging into the wall on the left side. Any help would be greatly appreciated.

Please share more:

  • What drives this laser?
  • What Device Profile have you selected in LightBurn?
  • How do you have that profile currently set (show the ‘Device Settings’ for this profile)
  • What is the physical size of your cutting bed?

Start with this and we can go from there.

I am using a Ruida RDC644XG controller.
Device profile: I believe I have the correct profile selected
Let me know if I need to show you something different regarding the profile settings.
The bed size is 1600mmx1000mm

I am also looking for the screen I show an example of below. :slight_smile:

Rick,
I appreciate your help. I finally heard back from the factory in China, and after running the diagnostic test, it is showing that the X limiter switch was bad. so I switched it and now the same thing is happening in both the X and Y axis. When I run the diagnostic test this time, after putting the new limit switch in, the red lights are gone, meaning the limit switch should be good, but the laser head is trying to go out bounds so to speak. Trying to go off the table, as if the limit switches aren’t telling it where to stop.
I hope that helps.

Testing that your limit switches are in good working order is a solid starting point.

Then I would still like to see…