Right arrow moves head left

In the ‘Move’ panel, clicking the right arrow moves the laser head left, and vice versa. the up down arrows work as expected. My ruida laser homes top right. Therefore “move x +” would technically be right and not left. It’s just not intuitive to have to click the rt arrow to move the laser head left- is there a work-around or correction?

  • Where is your machine origin? (never mind, you said top right)
  • Where have you set the device origin in LightBurn? (the Origin dots in Edit > Device Settings)
  • Do you have continuous jog enabled? (it’s new)

I had this and just changed a setting in smoothiware and all perfect

Yes device origin is set correctly (top right). Continuous jog is checked. When unchecked, jog reversed direction (moves as expected). Also my controller is in fact Topwisdom TL-410 not Ruida.