Roller Rotary & Ruida 6445G Not Working?

So i have a cloud ray roller rotary attachment that im trying to figure out.

I have Connected the Rotary attachment to the separate Rotary connection my laser machine came with. Now when i go to rotary attachment settings and enable rotary attachment & send the file to the laser, Select the file & Run on the Laser It Fires But just the X axis moves & the Y axis does not move the rotary.
Now When I Disable Rotary Mode it Will fire and Both X & Y Axis work but now whatever im working on is stretched out.

Now My Steps No Matter How Much i Change them It seems to always do A Turn And A Half! When I Press Test On Rotary Settings. The Only Way it will do a correct Full Turn Is If I Go to The Move Tab and change distance which is off By 14mm. Actual Diameter Of Cup Is 88.9 and It Does Not Do A full turn now if i put 102 it will do a full turn.

Chinese Laser 90W
Ruida 6445G V15.01.22
CloudRay Roller Rotary

Even When I Follow These steps! Lol

This is what works for me with V15.01.22 and the rotary connected to the U axis.

  1. Enable rotary in Lightburn
  2. Use ‘Start from current position’ in Lightburn
  3. Jog x and y on the Ruida to move the laser to the required starting point on the work
  4. Press ‘Origin’ button on Ruida
  5. Send job from Lightburn to Ruida
  6. Run job by pressing start button on Ruida.

Step 4 is the key to success.

Current position is where the head is located at the time…

I usually run with user origin… this requires you to position the head to some location… I set it to where it’s over the bottom of the graphic/mug.

Then press origin

Run the job…

I’m not sure what you are doing… setting the origin shouldn’t be required if the start from is set to current position

:smile_cat:

Hmm Just tried That with still no luck. it just moves The X axis up and down in straight line thinking its doing the graphic.

I’ll have to think on this one… If you use current position, position it, then press origin, it should work with either current position or user origin… because both user origin and current position are the same.

What is the return position you are using? It’s in the Ruida controller… machine settings show it right above the vendor settings if I recall…

:smile_cat:

Return Position Is Absolute origin

Mine is set to user origin most of the time… this will only occur after a job completes and should return it to 0, 0. Current position at that time would be 0, 0 and the origin would remain at the value when you press origin.

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.