Rotary (chuck), "position laser" problem

Hi, using an Ortur lasermaster 2 with their chuck.
I am commonly engraving on items around 7cm diameter. To save my remaining braincells I have chosen to set it for a 21cm circumference and for my 21 cm circumferential patterns it all seems to “join up” very nicely. If all the design is set to be “engraved in one session” whether a combination of scanline images and/or vectors it all seems to be positioned properly. What I am still befuddled with is the “position laser” aspect. the rotary is connected to the y axis. if the laser is on the y axis origin and it is told to go to 10.5 cm (ie a half turn) it travels for approx 18cm of circumference, if told to go back to the y origin it does so. Other distances lead to proportional overtravel.

Is it just possible, for whatever reason, that the “position laser” command uses a different rotary conversion system than that employed when actually engraving/cutting ?

This is mathematically incorrect…

70mm diameter relates to a 219.911mm circumference. Almost a 10mm difference from the actual size.

Did this in Lightburn, no loss of brain cells, so you have no excuse :wink:


If your rotary is setup properly it should reproduce consistent results.

If you give it an erroneous value and make it work… you’ll have to fiddle with any different sized object.

The Lightburn people will have to answer this… but I would think not.

It can also depend on the controller type…


Ensure the rotary chuck rotates 1 complete turn and back when you press the test button in the rotary gui. If this isn’t right it’s probably not configured correctly… and will continually be a problem.

Good luck

:smile_cat:

1 Like

Thank you for pointing that out (one of the reasons I mentioned “around 7cm diameter”).
Perhaps I should stress that the primary requirement is that the pattern meets up, I am willing to accept some around-the-circumference distortion. This is not suitable for a roller drive.
Yes, the chuck does manage a 360 degree rotation under test.
I do get consistent results when the whole design is to be formed in one run.
I also get consistent “position laser” overtravel.
Given that my machine is very slow at scanline image engraving I was hoping to build up a small stock and leave a small amount of vector text for later. That is why I wanted the “position laser” to match the expected rotary distance.
I hope that provides a better explanation.
I would be interested to hear whether any others have tested “position laser” on their chuck drives.

Hi @steeve, hi all,

I discovered the same error, I also use an Ortur Laser Master 2 Pro with the Rotary-Chuck.

I have the error since my update to 1.4.0, but I ran 3 or 4 months without a license and didn’t upgrade. So i can’t pin my previous Lightburn version.

In you previous posts I see that the problem might exists for older versions than 1.4.0 too?

Hope anyone can help us.

Best
Steffen

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.