Rotary home and frame

I need help. Have a OMT55 watt and a Omtech 4 wheel rotary. After doing set up and test, everything seems to be working correctly. I load my file and when I hit origin on Lightburn, the laser head moves to the left limit switch and continues to try to move until I shut the machine off. I had it working previously but do not know what my problem is. I have origin set to user.

Besides there is no ‘origin’ in Lightburn, but my Ruida has an origin button…

Sounds like you are doing a ‘reset’ from the console.

When you press ‘origin’ on the machine, it sets the current position as it’s origin, but doesn’t move anything.

In lightburn there is a ‘go to origin’ when will move the machine…

If you are setup like many of us, with the rotary on the Y axes, you have unplugged the Y table motor, so the machine will fail to home… crash in the Y direction… :frowning:

You are advising it’s crashing on the X axes.?

Any of this help?

I have a PiBurn rotary on my ‘China Blue’ 50 watt. Ruida controller is a 6442G

Hang in there, we’ll get it worked out…


I have the rotary setup on the Y axis. When I either go to bring the laser to the center of my file, frame my file, or hit origin for the laser, the laser head moves on the X axis all the way to the left and tries to go farther to a god awful sound, It does not seem to recognize the limit switch, I can use the controls to move the laser either with the Lightburn Software or on the control panel and the laser will stop when reaching the limit of the X axis. Does this help to clarify what I am seeing?

This ‘origin’ button is on the machine console not Lightburn.?

Unlike a grbl machine, the Ruida only uses the limit switches on boot. They are ignored after a boot.

I understand, but it doesn’t make sense to me. I’m still not clear of which ‘origin’ button you are pressing.


On lightburn, If I hit on the machine it is fine. That clarifies the limit switch question.
I am thinking that my problem is a setting I have in lightburn. Those buttons will move the head along the x axis all the way to the left.

I don’t think you should be able to drive it out of limits.

Once it’s booted properly it knows where it’s limits are.

When you press ‘go to origin’ it will go to whatever origin is set, but I don’t think it can drive a DSP controller outside of it’s area.

There is not an ability to ‘set’ the origin in Lightburn for a Ruida controller.

If you set your head in the proper position, then press ‘origin’ on the controller. Then with lightburn ‘go to origin’, I would think nothing would move, since it’s at the origin.

I run my rotary from the console, as my machine is in the usually colder garage.

I hope you saved your configuration before you did any modification to the Ruida for the setup. You need to write the original ‘no rotary’ values when you change back to the table.

Did you go through lightburns rotary setup?

I assume you’ve had Lightburn on your machine and it was working ok?


I did save the the original configuration and I have verified that it works correctly without the rotary setup. The difference between the machine and lightburn controls is a little confusing to me, but I am getting my head wrapped around it.

I have not changed any of the settings on the Ruida Controller. Not brave enough to do that yet.

As long as you have a backup, you should be fine. I have one on my Google drive, in case my home stuff gets clobbered. Always have at least two backups in two different physical locations, preferably off-line.

To get any kind of good work out of a rotary you will have to slow down the rotaries speeds. I have a few configuration for both regular and with a rotary.

I’ve slowed my acceleration and speed values way down.

When you use a menu, take a few on check out the documentation on that menu. The docs are relatively short (sometimes too short) but can clear up a lot of misconceptions.

Take a few and check out the Coordinate and Job Origin.

Good luck.


I have it figured out. I was having a problem understanding the whole machine vs. Lightburn origin. I do appreciate your help jkwilborn.

No perspiration… I was thinking we had a communication issue.

Glad you figured it out…

Take care


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.