Rotary issue just started

I have been using the rotary attachment with the ruida controller without issue. Tonight I tried to set the circumference of my piece and that’s when the stepper started acting up. The steps per rotation seem to be way off. When I try the test button in the setup the piece turns at least 11 times now on hyperdrive. When I frame the piece the stepper now just hums. I up the steps to 760 steps per rotation it acts the same as described above. At 770 it goes to a snails pace and moves the piece approx. 30 degrees of a full rotation.
Pulling my hair out… Any assistance/suggestions would be appreciated.

Did you back it up so you can restore it?

It just has to be something you changed, they seem to go hand in hand.

Good luck

I haven’t backed anything up for a restore… not sure how to do that, I will look into that for the future, but I’m also pretty confident that the steps per rotation value that I had been using was 360. My thought is the stepper motor is messed up somehow… I took it all apart expecting to see something obvious but they are very straight forward, nothing obvious to me wrong with it.

In anything back up, the first step before anything. Even if you don’t modify it, you should have a backup.

I assume you’ve gone through the LightBurn Rotary Setup?