Rotary issue(no "enable rotary" button)

Hi everyone,
I have a Thunder Laser Nova 35 using a Rudia 644XG controller. The rotary is a Rotoboss. I can manually jog the rotary with the laser so I know that is working. I set up the parameters per some online videos. The test button in the rotary settings does not do anything to the rotary. When I am in the main screen there is no “enable rotary” in the Laser window. I did enable rotary in the rotary settings. The software is forcing the rotary to the A axis. When I try to run the file the head wants to go to the origin in the back left of the tool and trace a large square then stops. Any suggestions.

‘Test’ doesn’t work because you have a Thunder Laser controller, and they use the U axis (also called A axis) for the rotary. The rotary switch on the main panel has to be enabled in the settings if you want it there.

When you say “when I try to run the file” - are you clicking ‘Start’ or ‘Frame’, or something else?

I sent it to the laser and tried to run it from the laser and also tried run from lightburn.

And you’ve plugged in the rotary, and set the rotary enable switch in the Rotary Setup menu in LightBurn?

Yes the rotary is hooked up and working since I can manually rotate the rotary using the controls on the laser. The rotary is enabled in the rotary setup menu. There is no rotary enable in the Laser window(lower right hand corner) of Lightburn. I’m not sure if this is the issue. I was able to burn the image on a flat surface prior to trying on the rotary so I don’t think there is anything funky with the file itself.

Click the ‘Gears’ looking icon at the top-center of the LightBurn main window to expose the ‘Settings’ window where you can turn that feature ON (green). Did you do that?

OK, so that corrected the missing rotary enable issue. I still don’t know why the rotary is not working. I won’t be able to get back to it until Wed. Thanks for all the help so far.

@TechBravoTN, What are some good things to know/ask to help sort this? Thoughts you can offer? @LightBurn?

The only possible thing I could think of is that multi-origin mode might be enabled, but that would mess up normal cutting too, not just rotary.

I am finding, since we use the u channel for rotary, that the enable rotary switch doesnt matter on thunder specific dsp’s. thats not really help but noteworthy. i havent “officially” confirmed that but many reports support this.As far as forcing A axis this is correct. I think A is U. the test button in the rotary settings will not work correctly, again due to the U axis thing. You have to send it to the controller and frame from there. the origin thing sounds like they are using absolute coords instead of current position.

I am back with some pictures. I am trying to engrave this buffalo on a pen blank. Today I can only get it to move if I send the file to the laser and run the file from there. It doesn’t run right. I did a test burn on a piece of plywood in the upper right of the bed. The rotary is in the lower left. The buffalo printed just fine on the plywood. When I attach the rotary and start it from the laser the lense moves to the previous point where the buffalo was engraved on the plywood and starts to engrave there. If I use the start button from Lightburn, the laser does nothing.

Well after some fiddling around, I got it to work but not as I think it should. I don’t understand why it is doing what it is doing. If I move the head over to where I want it to be on the rotary and run the non rotary version of the file(using the start button on Lightburn) then hook up the rotary and run the rotary file version(from the laser), everything works.

There are no differences in the file itself - The rotary setting is something that is enabled on the controller, not in the file.

2 posts were split to a new topic: Rotary enable not working

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.