Rotary problem!

Hi, I have an Eleksamaker A3 pro for 3 years and I use T2Laser(it’s a purchased program). Recently i try Lightburn in order to buy a licence. Everything work perfect!!! I also set up the rotary to match my drawing with the glass, BUT when i tried to engrave i heard a clicky noise at the motor of y axis(the axis that turns the glass) and i realised that it tried to move but it didn’t or like a force turned it the opoposite way. when i shape my work it works fine, when i press start to engrave it stays stuck to the same y position. With the exactly same settings i tried T2Laser and worked flawlesly. Is it possible to give to the stepper motor 2 instruction( one to go front and another to go back)??? Or is it possible because of the little movement on the y axis it doesn’t move at all??? Please help me solve it as my main work with my laser are the glass engraving and to be honest i like your program better than T2. But if i won’t be able to engrave on glasses it will be unworthy. Thanks!!!

Did you follow the Lightburn Rotary Setup?

Here’s a video that might help… Setting up Ortur YRR Rotary Device in Lightburn using lightburn.

Generally you should be able to get going. If you follow the generic lightburn setup you should be able to make it go… :crazy_face:

If all else fails and you need more information, try

This is the setup manual for PiBurn Rotary. It goes over how to come up with the steps required and a few other things that might be of interest to you.


i tried with the a axis but nothing. It doesn’t even move. I saw the video but he also used y axis even though the manual suggested using the a xis for grbl. With the y axis it frames very correctly BUT when i press start it engraves at the same y spot.

Hi, did this rotary ever work?

I don’t know anything about an a axis. That leaves me useless there. Most of the machines use the y axis, as does my china blue.

If you are hearing clicking noises, that would indicate you don’t have the proper step configuration for that motor/controller. If you’ve read the PiBurn setup, you will note you need to know other information to come up with the correct step rate.

I would think if the rotary worked at all, that it would at least do the basic movements, even if they were not accurate.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.