Rotary U axis for LightObject R6 (6445G (EC) FIXED!

I can’t be every all the time guys. I run a growing laser forum on FB that keeps me very busy.
And I don’t understand the problem with the firmware. Install it. You can move to any firmware at anytime, so what’s the hold up on trying it out? I don’t change it from the software because there is some bugs with it. For what ever reason, you need to change it from the DSP screen and then switch it over on Lightburn’s side. LB doesn’t fully control it. Likely because it hasn’t been tweaked for this new firmware yet, or Ruida changed something on their end with the firmware… Who knows.
Anyhow, Once you do it that way it should work fine. If it doesn’t for what ever reason, turn the DSP off and on again. It should work fine.
As with going out of rotary mode, I did have it act wonky once I turned it off once so a reset fixed that issue as well. Basically I suggest experimenting with it a little. Worse case scenario you have to reset the controller. Not a big deal. Try it and drop some info on what works for you.

I have ben trying to get it to work now for a while. I updated the firmware, set the rotary enabled on the control panel. Download a job. Hit frame and everything works as expected: X moves, and rotary turns. But when I hit Start the rotary just takes off for a bit then stops with a frame slop error, and the Y axis shows 10366 (I have a 1000x600 bed). And I can’t get the job to actually work.

Seems like a bug in the firmware.

I also have a problem with the U axis …
I updated the firmware and set user origin and rotary axis but when I press the play button the laser does not start and I do not even signal any error … if I send the file to the controller only the rotary axis turns but the laser does not work and neither does the axis being scanned

Just joined to get some insight on this topic. I purchased the 6445G for an upgrade. Believing as advertised it was a 4 axis controller and leave the old shared Y axis behind. Wired it up for independent 4-axis control as X,Y, Z and U. Just discovered the U-axis is intended for passthrough feeding between cycles. Could not believe it was incapable of driving the rotary 4th axis motion. Which as shipped technically makes it only a 2 axis with one of those shared and 2 aux drive outputs. I did install a custom Z motor drive for convenience.

I am really hoping this firmware patch is viable. I can rewire for a Y-U-axis toggle switch to redirect the Y-axis Step/Direction signals to the rotary drive. Just sucks that also requires a parameter load/reload on every changeover.

Seems to me the title to this thread shouldn’t have FIXED! in it.

I don’t understand what the deal is with your controllers fellas. I updated my unit with it and had it working just fine. The only discrepancy I found that was annoying was the scaling. But if you shrink the image down 50% from left side to right side, it was pretty much exactly right. The height didn’t need adjusting. The problem is, I sold the machine that had that controller in it with the rotary.
I know there was a strange effect that i ran into that forced me sometimes reset the controller via the reset button after I switched to the rotary from the controller. I also restarted lightburn after I did this, then set the tic box to rotary. This worked every time for me. I could move the gantry with the up and down arrow keys where I needed it to be to get the rotary centered. And the U buttons worked the rotary just fine.
It doesn’t make any sense why this isn’t working for you guys when it did for me.
I have seen it work on two separate 5g units. One from cloudray and one from lightobject, so its not controller specific. Make sure you set up your UM settings in the rotary settings menu. Dont push the Test button. IT will just make the system walk away slow. Some sort of conflict with that botton.
Once that is done, make sure you have the U axis limit disabled. Make sure to “write settings” then close LB. Go to the panel and switch to rotary mode, then reset the controller. Then open LB again and make sure the rotary box is checked. Try it and let me know what it does after doing all that stuff.

And I’m just going to throw this out there.
Ruida has been a real PITA to get their engineers to do anything as far as simple firmware patches goes or even bothering to do something as simple as correct their menu grammar error, such as “Manufactory settings” FACEPALM… For two years I’ve tried and tried to get them to work with us and so has LightObject. Bottom line is they don’t really seem to care or can be bothered with anything other than selling you a half $#@ system IMO.
On another note, Trocen has really stepped up to the plate for us with their 78 series touch screen units.
Tiger Chen (Trocen’s head programming engineer) has been directly talking with me for the last couple months to develop and patch multiple firmware revisions at the request of the users needs.
They have made their units have features such as dual tube layer type function, (IE run glass tube for vectors and RF for etching) without needing to run separate jobs. They have multiple air assist shut off/start up options, and they just released their beta firmware to my two days ago to enable standalone U axis rotary for their 7824 series controller and they are working vigorously to comply to LightBurn’s requirements to get it full featured and compatible.
I was hesitant at the idea of a touch screen at first, but once I got it in my hands I was very pleased with how well it functions and the features it has. So far I feel like the S curves have improved the raster accelerations to be much more responsive. I don’t get paid for doing any of this stuff and have no reason to suggest it’s a better unit. But it is. And I suggest you try one out.
If rotary is important to you, go for the 7824 model. That is the series unit I am doing most of my beta testing and firmware request for.

Would anyone have access, can provide a copy or a link to the 6445G(EC) firmware RDC-15-01-19 ?
I’d like to experiment with the patch, but I prefer the ability to restore the existing firmware if things don’t go as planned. Sounds like there are still quirks to get it to work using just the right magic hocus-pocus sequence of events. Neither Cloudray nor Ruida has responded to my request.

Pffft… That sounds about right. Both of those companies are non-responsive 90% of the time.
If all goes well with this whole Trocen deal, I’ll never go anywhere else again unless a US vendor makes an LB controller in the future.
Hold tight. I’ll get the firmware site pulled

Appreciate the link Hooeson.
So they don’t really know if it’s really 19, but they post it anyways with a warning? Not exactly comforting with no point of return.
Very surprised there is no super secret…hold this/these button(s) down on boot to export firmware as a backup.
I do wish I had known about this issue before I committed to the Rui duh. Feeling kind of duped with all the flash and splash and not enough substance.

1 Like

@electrotech feel the exact same. There was another thread that had high praise for the RDC6445G and I’m not sure why at this point.

I successfully flashed the 15.01.22 firmware from LightObject but still no U-axis rotary control. The control panel U+ button spins it as expected, just no control from LightBurn.

Guys, are you switching to the rotary from the DSP? Because this has to be done first.
Switch to enable rotary, make sure you then choose “Write and enter” at the bottom right of the screen. Then reset the controller. Now open lightburn and check the rotary button. Try this in that order and report what you get. I am not understanding how I am the only person to get this working. Surely it’s something you’re missing I would think. I got this to work on two different units from separate places.

Note that the setting you see above showing Circle Pulse 4800 and Diameter 67mm is the correct values for a typical 2 phase driver set to 3600 micro steps.

I’ve been switching on the rotary from the machine settings in Lightburn, but I tried again using your approach from the DSP. Same results. I draw a square in Lightburn, click start, and when Enable rotating is set to yes, nothing happens. No error messages, and no movement from any axis. When I disable rotating, X and Y work as usual.

The Rotary Setup screen in Lightburn still never shows the Z or A axis as being selectable. Is this the case for you as well?

My steppers are three phase. And as I said, the rotary tool moves just fine when manually pressing the U+ and U- buttons on the control panel.

Ok there are a couple things I am not seeing on your system, but that may not be because something is wrong, but compare what I have here. Copy it all to the T. And what is your microstepping? What sorta rotary? If it’s the black 4 wheel unit like most, set it exactly like mine.

Screenshot 2021-01-28 20.34.12

Set your machine to “User Origin” and why don’t I see that rotary switch on your copy of Lightburn?

Hi Vectorspace,
This thread was started by Hooeson with excitement it was working for him.
I still have no response from Cloudray or Ruida on getting a copy of the 15.01.19 firmware. I’m not loading anything unless it is that confirmed version.
Poor customer support is just inexcusable. I can imagine the increase in sales volume if they would as least make the firmware open source where end users could make these controllers fit their application.

@Hooeson Sorry for the delay. I’m not entirely sure why my version looks different from yours. I’m fairly confident I’m also running 0.9.20, but I’m not sure how you brought up the Controller Status Info window. I tried every option in the Help dropdown, but no luck. Could this be because I’m running on Linux and you’re not?

I modified all of my settings to match yours perfectly, and still no luck. Same result as before: when I click start, there are no errors but there’s no movement from the X or U axis and the laser never fires. Again, with your settings, the rotary motor moves just fine using the control panel U+ and U- buttons, which makes me think this is a software issue.

I’m using a homemade rotary engraver with a 57BYGH350C three phase motor and a 3ND583 microstepping driver wired to the U-axis of the Ruida 6445G controller.

@Electrotech I agree and feel the same way about LightBurn itself.

Well, embarrassing enough I have yet to invest in Lightburn until it can prove what I would expect as an HMI with true 4 axis. Certainly worthy of consideration in competition with RDworks. It does not appear anyone has any real influence paired with the controller OEM’s we invest in. Both seem to be trying, Just no collaboration. Language barriers? Motivation barriers?

So I might have figured out why you guys can’t get the Rotary to work.
Strange I know, but you need to download RDworks if you don’t have it
From there you need to close LB and then install RDworks and let it install the drivers to your controller as well
Once you’ve done that, open RDworks and check to see that all the setting throughout the Vendors settings (password RD8888) is the same as they are in LB. If not make it that way in RDworks after the Vendor settings are password opened through the RDworks UI. There are several menus you will need to go through, but this was the only way I was able to get a couple different people’s systems fixed for things like recognizing the laser test pulse, due to some sort of conflict with LB bypassing the vendor settings to write things to LB’s “Machine settings”. I know this sounds confusing, but try it and then report. Make sure LB is closed when installing and don’t open it again until you’ve went through everything and then saved settings through RDworks. Once this is done, you can try to setup the rotary with RDworks and see if it runs that way
If you can get it to work there, then you can try to run it with LB again.
There is no easy answer to this guys, but I think that might be why some of us are able to get it to work and others aren’t that are using LB. RDworks is basically necessary for full vendor/device settings compatibility it looks like as well as for installing firmware. But try the RDworks Password and then check things and write everything again with RDworks, then open LB “machine settings” READ then, save it with write again. You might need to change anything just a slight amount like accelerations speed by a percent or something so that it will WRITE from LB again after you do all that stuff aforementioned. Please let me know. I won’t stop till know what it happening so bare with me.