Rubia control connection Lightburn

I need help please. LB no longer finds my laser, I have a black and red Chinese 60 watt with the Rubia control. I am using a USB cord across the room due to the fact that is where my machine is and there is no place for my computer to be set up. I use to never have any issue but over the last 6 months it has changed. Most times I can restart LB 6 or 7 times and it finds it, but it’s gotten to the point it will not even do that anymore. I try to setup a laser and it still doesn’t work. I am pulling my hair out because it just won’t work.

I’ve tired to message LB staff and they seem to have messages turned off, that’s a big help!

USB isn’t the best way and an extra long one doesn’t help. I’m sure many will suggest you swap out the cable.

I ran Lightburn a very limited amount via usb to the Ruida. I found it frustrating and used the same length cable for the Ethernet connection on the PC and ran it that way.

When in Lightburn, you can right click on the ‘device’ button and Lightburn will attempt to reconnect.

Can you tell if the Ruida is showing on your usb ports? I can do it on my Linux box, but clueless on Windows…


Long USB cables are not recommended.

I was speaking with Oz at MRRF last weekend about the use of CAT5 and CAT6 Ethernet cables with USB converters. They are set up to cancel inductive reactance and stray electrical noise. Exploring this may offer a long distance USB solution for you.

One completely tangential thing that can make a Ruida controller slowly go awry over 6 months is having full memory and too many stored files on the controller itself. Just double-check to see how many you have stored up - you may want to knock out half of them to get going again. You’ll have to do that at the controller itself.

With respect to line or data loss, over the last six months, (besides updates) what else has changed? Any new appliances? Any new lighting? Any new USB accessories on the computer?

Any electric motor used more often can also cause electrical interference. The increased demands of domestic air conditioning loads in the summer months can cause communication problems. Seasonal changes in humidity can also impact the capacitance of the insulation. (Internet via buried telephone cable is an excellent example - we’d have slow internet about a day or two after a hard summer rain and humidity in the air can behave similarly with insulated wires.)

One customer in the UK had to move a freezer to an extension cord and to a different circuit in his home as the freezer would cause communication errors.

Personally, I had to move my exhaust fan for my Diode laser (USB communication) to a different outlet to avoid putting that motor noise on the circuit powering the engraver.

I recommend starting with the hardware side and any recent changes

  • then verify the USB cable connections are fully seated to and from the computer and then within the engraver cabinet.
  • I would then unplug the controller from the USB cable in the black and red cabinet and connect a USB device to that cable (inside the cabinet of the engraver) to attempt to verify the integrity of the USB cables.
  • I would then look for evolving grounding issues and noise within the cabinet with a DVM or an oscilloscope because mine were loose and caused problems.

I feel that this path resolves about 80% of Long USB cable scenarios but check the controller memory first - I’ve seen that nuance catch some pretty clever folks off guard.

I hope this gets you going. Please report back when you get unstuck and working or if you run out of things to try. I don’t suspect it’s anything insurmountable.

What I didn’t suggest earlier was to run an Ethernet cable to the laser. I use an existing port on the pc to for a direct connect Ethernet. With the Lightburn bridge, I don’t do it often anymore…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.