Ruida 60W red black laser slow speed

no matter what speed i put in it only goes 1 speed has one else seen this issue

also this is a new machine,

Do you have this same issue using the software that came with your system? You identify you are using a Ruida, so that would be RDWorks.

downloading it now and going to test it out

downloaded Rdworks and i was able to change speed in that software , is there a way to restore light burn to defaults or should i just reinstall?

You can delete your prefs file but back it up first. Quit LightBurn then rerun to build a new pref file and do the initial device setup again. Please report back. :slight_smile:


delete the pref files and did a full PC restart , and still the same slow speed , when i hit frame the speed noticeable faster then when i hit start. any other setting or files i can delete? :thinking:

Can you show a screen shot of your main ‘Cuts’ list window, and your Preferences? It’s possible you have your settings in mm/minute, not mm/second, which would make everything go much slower. It’s also possible you’re in inches/sec, which would make everything go much faster, but then the controller would limit you.

You’ve said “everything goes 1 speed” - do you mean 1, as in 1 mm/sec, or “one speed” as in it all goes the same speed? If your speeds were in inches/sec, Even 10 inch/sec is 254mm/sec, and 20 would be 500mm/sec. Most machines are capped at 500, so if you entered a number larger than that, it would limit you to that speed.

hopefully this is what your looking for

Can you post a picture of your controller? I’ve only heard about this from one other user, and it was with a very new 6445 series controller.

would it make a difference if i try to reinstall LB ?

I doubt it - The controller you show is a pretty normal 6442. It could be new firmware that I haven’t seen before.

When you say, “no matter what speed I put in it only goes 1 speed” - How do you mean? When using the buttons on the controller? When cutting a shape? When hitting the frame button? I ask because each of those uses a speed setting from a different place.

  • The jog buttons on the machine use a speed value that you enter in the controller itself
  • The frame command or jog in LightBurn uses the speed in the ‘Move’ window
  • Cutting and Engraving use the speeds you specify in the cut settings

So be as descriptive as you can - we don’t charge by the word here. :slight_smile:

i put a square shape set a speed and power , i did not turn on the laser. i hit start and it goes a set “slow speed” no matter what number in [speed (mm/sec)] , if i hit frame it goes noticeably faster then when i hit start in LB , i am only using the buttons in LB

i could also check if my k40 has this same problem i will report back if i find anything out

The K40 does fine with changing speed settings, its has a smothieboard

You said RDWorks does do what you ask it to. In that case, use each program to create a small test file with a rectangle in it, using the same mode (Current position, or User Origin), and the same size and speed settings. In RDWorks, click “Save UFile” and in LightBurn, click “Save RD File” (they’re in roughly the same spot).

Name each file according to what program made it, and send them to developer at LightBurnSoftware dot com with a short description and a link to this post. I’ll see if there’s something in the RDWorks version that’s not in mine, because this doesn’t make much sense.

1 Like

sent , hopefully its something simple.

so i was trouble shooting some more and with different colors/layers in LB and i notice some colors worked , check each layer setting i noticed [Dot Mode] was toggled , i dont know if this is default or something i did but after switching that off the speed setting is working now, also I installed the 9.0.5 and made sure the driver [dsp] was installed

Not the default, no - you likely set that without realizing it at some point. In the cut setting editor is a “Reset to default” button on the bottom left. That will wipe the setting to it’s default, with all the advanced options disabled.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.