Ruida 6445G: Set Blower to "processing" via Lightburn?

Hey Folks,
is it possible to set the blower (connected to WIND on controller) to whats called “processing” in RDWorks? When I run Jobs via Lightburn, the WIND-Output is switching with each Laser-Fire. I would like the blower to be running for the whole layer without interrupting.
In RDWorks this setting is changeable, but I cannot find it in Lightburn?

Thanks a lot & best regards!

This might help

About minute 2.00


Hi Gary,

Thanks for your reply.
The question for me is, is this setting also available in lightburn?

Thanks a lot,

I believe if you go into RDWorks set it there and write it to the controller, then it will remain with that setting.

Personally I have not seen it in LightBurn and over that last 8/10 days I have looked at just about every setting in there.

Good luck with finding an answer, I will be following with interest :slight_smile:

If it is in LightBurn I would go to Edit, Machine settings and take a look in the panels there ,:thinking::crazy_face::crazy_face::crazy_face:

Unless something has changed recently those setting are not available in Lightburn. I wish they were.

I have gotten the impression from my searches so far about this that it might not actually be a machine setting. They may be saving the value in RDWorks and the sending a new command in the actual cut file/stream that says to use the new style of air assist. I’m attempting to verify that in the UDP stream when making a cut, but I haven’t gotten it done yet.

Id say you were on the right track in that, ( and I havent gotten to the bottom of the RDWorkd / LightBurn working together to control things partnership ) but, the controller accepts certain settings.
Those settings can come from RDWorks OR LightBurn IF and its a very relevant IF, the program has the options to set those specific parameters in its library of settings, IF NOT, you simply cant make the change UNLESS to go to a program that does.

In this case Lightburn does not have the full bank of options re Air Assist BUT It does have some …HOWEVER ( IN THIS SPECIFIC CASE ) one level below ( Deeper) than the Lightburn access is the RDWorks layer, in which the “while laser firing” OR “through process” is set. Then those very important parts of a job specification are included in the command chain sent to the laser when a higher level request "Air assist YES OR NO " are constructed and sent.

So I really do think you are barking uo the right tree, one of “The guys” will hopefully read this and say
Yes thats roughly it :slight_smile:

I was finally able to get RDWorks running in virtualbox without communication errors and capture the packets. It looks like my impression from googling was wrong. Setting to “processing blow” (which gives you the old normal behavior of per layer) is done by writing 0x100000000200 into address 0x18f. writing a zero there gives the new behavior of “laser on blow”. That value seems ridiculously high, but I probably don’t quite understand the ruida protocol. There is definitely a difference between zero and “something” there though, so it does seem to save it to the controller.

Alright, after a brief delay caused by covid shot #2 leaving me as the no-so-walking-dead yesterday, i cleaned this up a little. It looks like for some registers, including 0x18f RDWorks is sending the value twice, and my decoder was too dumb for that. Maybe @LightBurn knows why the ruida protocol does what it does.

RDworks writes a 0 to 0x18f for “laser on blow” and a 0x200 for the old behavior of “processing blow”.

I added a feature request here, upvote if you want it i guess?

For posterity since I might be decoding it wrong, here are the actual UDP packets:

Raw UDP packets
laser on blow read:
processing blow write:

processing blow read:
processing blow write:

kind of the same issue here…just installed solenoid, turn on, but won’t turn off again unless I break the circuit. Both when connected to +24v/Status or +24v/wind. I hoped I could get it fixed in the blow type settings, but exclusively mac in the house, so no possibility to acces through SDWorks. Any workaround would be welcome!

I have just done the air assist install and tried it without going change from 'while laser is on’and sure enough, click, cick,cick then, once set in RDWorks to Process and written to the controller. I went into Lightburn and scan filled a piece and it worked as expected, on at the start, off at the end.

Just a note, you controller 6445G 'SINKS Electricity’it provides a path to Earth…it does not provide +24 volts DC

Can I suggest you borrow a Windows laptop for 15 mins to set RDWorks, its worth it :slight_smile:

For a laser control software, it should be able to control all aspects of the controller settings. It should be possible to add a feature to lightburn to set this blow setting without having to invest money/time in setting up virtual machine on MacOS. I do have a windows laptop, but it’s so slow it’s not even usable. I don’t want to have to invest in a Windows laptop that I may use once to set this, and never again.

I’m sure in the near future it will be possible, great strides are being mode, daily and weekly in the functionality.

Air assist is getting more popular on all types of machines and by a growing number of users, so it seems logical for that function to be added.

No great speed is required from your Windows machine to do the change, as I’m sure you know.

Good luck and hope it all happens as quickly as is practicable.



And a 0x600 for “Keep Blowing”

Hi Bouke i am from Ghent,
Had the same problem as yours, place a 24V relay between the output and your solenoid. Take the 24VDC from the power supply directly for your solenoid, never forget to place a .diode (blus-diode) on your relay and solenoid. Hope this is helpful four you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.