Ruida Controller - Machine ignores homing sensors

Referring back to my original steps, you should have done that after enabling X axis homing, after plugging the motor into the driver, after verifying the controller senses the switch, after installing the switch.

Did all that happen in the proper sequence?

Remember, we (I, in this case) have no way to see what you’re doing and no way to know what happened. The best any of us out here can do is provide some detailed instructions and ask for observations: help us help you.

I should have clarified - yes, in that proper sequence.

I got stuck when I clicked reset on my controller. When I click reset, I heard a small noise (kind of like a stepper motor first getting power), and the screen briefly showed some text about resetting. (I can get a photo of this if that’s helpful)

Indeed it would be!

Unless that message shows a distinct error condition giving us something more to analyze, here’s the situation you’ve described:

  • The home switches correctly detect metal objects (when dismounted)
  • … and the gantry / laser head (when screwed in place)
  • The controller correctly sees the input signals (active and inactive)
  • … on the proper inputs (X- and Y-)
  • … with the proper polarity (active = “red indicator”)
  • The controller is set to move the laser head toward the home switches when it resets
  • … and does so
  • But the controller does not react to the switches while homing

@jkwilborn had a situation eerily similar to this:

  • An input to the Ruida controller had the proper voltages
  • And activated the diagnostic panel’s indicator showing the controller “saw” it
  • But did not trigger its function

If that’s what’s happening to your machine, then IMO you have eliminated everything outside the controller that can be contributing to the problem, which means you’re in need of a new controller.

Not the happy ending any of us wanted, but …

Here’s an image of the screen during reset - nothing I can see that shows an obvious error:

I don’t this would affect homing, but may be worth mentioning - my main door has been open throughout all of these tests - so the door switch has been “open”.

I appreciate your help with working through this. Pretty frustrating that the controller appears to work fine for other features/functions, but is “faulty” with homing.

The photo is before it completes booting. It shows the firmware version while it’s booting.

An empty window is expected along with 0, 0 for the X and Y. If you have it returning to user origin, it will move there after it boots.

:smile_cat:

Here is an image after it has completed booting:

I will need to check settings for user origin, but it does not move after a reboot or power up.

No problem with that, nor the Water Protect signal: it’ll happily initialize, but you can’t fire the laser.

That’s different than the original problem, where it started the home process but ignored the switches.

Have you re-enabled homing?

Okay - good, just double checking.

Yes, you’re right, it is different than the original problem, but I didn’t realize it was an issue until we started talking about it.

I have only ever been able to home through the Lightburn interface. However, for the tests you outlined, I used the Reset button on the machine control pad - this is when I noticed that no homing/axis movement happened.

To make sure I understand - are you saying to re-enable homing through the Lightburn interface, and then click Reset on the machine controller?

Yes.

The Ruida controller handles all the homing functions and, in particular, the first home as part of the machine startup when you turn it on. LightBurn can tell the controller to perform a homing operation, but that depends on having all the machinery working correctly, which was not the case two dozen posts ago.

You must use LightBurn to change the axis homing setup (through Vendor Settings), because that’s the only way to get access to it. I suppose you could run RDworks for the same purpose, but I have no experience there.

So all the steps I suggested earlier use LightBurn only for changing the homing setup, not for doing the actual homing.

Review the summary to make sure you’ve done & observed everything in the proper order.

If the X axis now does not home when you turn the machine on or when you poke the Reset button on the controller console and you have re-enabled homing for the X axis, then something new & different is going on than before.

I have confirmed that homing enable is true on both the X and Y axes.

I powered down the machine and powered it back on - no automatic homing occurs (I believe you said this should happen if everything is working correctly).

I also double checked the reset button - no homing or axis movement happens after the reset.

Are there any other things I should be checking, or do you think there’s an issue with the controller itself at this point?

That’s what I thought back when you said the home switches work, they show up in the controller, and it ignores them while homing.

Now you’ve enabled homing and it doesn’t home, so things have gone from bad to worse.

You mentioned at the top that it’s a used machine, so the controller may have been subjected to all manner of indignities, of which we know nothing, and it may have internal damage or bizarre setting misconfiguration.

AFAICT, the RDworks program can access settings not available to either LightBurn (through the Vendor Settings) or the machine console, so setting that up and seeing if anything interesting shows up might be helpful.

You can try making a backup of all the settings using Edit → Machine Settings → Save to file, explore the machine’s console to find the Restore Default Factory Parameters screen, figure out which password applies, then do the thing nobody should ever do.

That might un-wedge whatever’s kaflooie, whereupon you restore the backup you just made and it will Just Work™, but I don’t believe that either.

Yick & similar remarks.