Ruida controls not showing in lightburn

I have a Linux box (desk model) and it has been used, as with my other machines, with lightburn for my grbl solid state laser… I have acquired a new Chinese model with a Ruida controller. I have purchased the license. The upgraded license works on the spouses machine that I haul into the garage for usb connection. I don’t have a network so the best option is by sneakernet. :frowning:

My Linux box is a different issue and since I develop on it, I need the options that are available only on the Ruida. I have ‘unlicensed’ it, then ‘re-licensed’ it after purchase of the Ruida license. Same procedure that I used on the spousal units windows box. I cannot seem to find a way to tell lightburn I really have one even though it isn’t hooked up… There is only ‘GRBL’ and ‘iLaser’ available in the drop down.

I’m hoping the resolution to this is not playing sneakernet the desktop… Maybe some config file I could copy?

Thanks…

You can export existing Device Profiles you have set up. Then import that profile on another system. :slight_smile:

Thanks I was going to drop by and post the resolution, you beat me to it. After it was up and no response I sent it to support and they were right on it. Worked well, but wonder why it wasn’t available as a choice. They only advised it should have been.

Thanks for posting it for others. Take care.

I am glad to hear you are sorted, but please allow time for us to get to the post. Sending multiple flags up for help creates more work than is required.

I am still not following what you mean when saying, “wonder why it wasn’t available as a choice. They only advised it should have been.”. What is the “it” you are referring to here? If you are using the DSP version, we do present the Ruida profile. You can see it when adding a device manually like here: