Ruida Laser, Not enabled past a certain X Point

Just have a wierd one where my laser isnt firing. I have a “red black” ruida 6442 Chinese cutter.

I’ve Doing some testing and if head is all the way to right it works, approx a 50mm range. Move a bit left it goes off. There is an audible click when moved and a light on psu goes off. Any thoughts? The Y axis is perfectly fine. I Only have homing limit switches and I have tried disconnecting them but it makes not difference.

Video of the problem.

Do you have the travel limits set correctly in the machine settings?

They are set as they always have been @ 400mm. That was the first thing I tried, by increase it to 1000mm (600mm more than that machine) to see if that made a difference but it didn’t

It actually happened mid work. I was doing an engraving job, then halfway throug I noticed only the right 50mm was engraving :confused:

Have you looked on the controller panel to check the status lights? (I think it’s ‘diagnoses’)

yep so I went to diagnoses, First time, none were lit… Then i mucked around and went to where it was off, then it shows XY limit lit. Then I moved back and forth and they werent. Its a bit intermittent there. Definteily I think its some kind of “limit” issue, but Not sure what.

Do you know if theres a way to turn off any software limit?

It’s very odd - I’ve never seen this behavior before. Are your limit switches inductive? Any metal passing near the X limit that shouldn’t be?

They are the Clicky snap limits…nothign odd I can see, I testing the limit switch with a multi meter and they “seem” to be working ok and don’t fire unless clicked.

Seems hard to troubleshoot.If its a replacement part job I dont know what to replace, whether its the controller or the PSU :expressionless:

The “easy way” to test them would be to short the wire on the X limit on the machine. Limit switches are usually “normally closed”, so if you short them, they can’t be interrupted. That would eliminate noise from the switch. It’ll make homing a bugger though.

thanks I’ll do a bit more playing around with the hardware limits when I get home to try and isolate them off

Ok further testing. the P is already jumpered to G… when to the right and P is on and laser fires, I push test and both come on so it looks ok.

WHen I move to left and P is off, then test no lights come on.

I unplugg P, and push test and L comes on, wierd thing though with P unplugged when I move to the left the point light still goes off…

Is it likely to be the Laser PSU even though the test to the right shows it fine??

Or could it be the Main Power supply (one that looks like this
not the tube power supply? very Wierd :frowning:

Thinking because the point goes off as well it can’t be the tube supply?

Ok I have it sorted. YAY it was the laser pointer that was causing it somehow… perhaps a cracked wire? not sure… now thats unplugged it all works… YAY. I dont really use the pointer much anyway tbh. although I should now with the new lighburn registration feature :slight_smile:

1 Like

It could be rubbing at some point in the drag chain, and when that point in the chain bends, it pulls the wires apart, and when it relaxes they touch again. A 5v direct short could cause power drain or weird ground loops or something. That’s very interesting that it showed up this way. That’s one for the ‘weird things I’ve seen’ category.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.